Archives Mensuelles: décembre 2015

Re-listage des programmes sous Wily 215

Par défaut

*BUGS: Le clavier de azerty devient souvent qwerty, il faut donc et enlever le clavier anglais et enlever le français qui fait qwerty. Actuellement j’ai les claviers (keyboard): Français et Français (variante obsolète) sinon les mots de passe restent bloqués.

*Le Grub côté Ubuntu (je l’ai des 2 côtés)*
sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get install -y boot-repair boot-info
sudo efibootmgr -v
sudo grub-install
sudo efibootmgr -v

*Des trucs qu’il faut installer ou mettre à jour*
gnome-color-management
Prise en charge des langues

*Personnalisation de Ubuntu*
sudo add-apt-repository ppa:ravefinity-project/ppa
sudo apt-get install vivacious-colors
sudo apt-get install vivacious-folder-colors-addon
sudo apt-get install ambiance-blackout-flat-colors
Unity Tweak Tool – personnalisation de Ubuntu
/usr/share$ sudo chmod -R u+wxr icons (pour pouvoir re-personnaliser si nécessaire par exemple en rajoutant les bonnes icônes)
Other option not installed, tu manually click folders and add them their colors by right click on folders:
sudo add-apt-repository ppa:costales/folder-color
sudo apt-get update
sudo apt-get install folder-color
nautilus -q

*Sources de Logiciels* à mettre à jour en mettant wily au lieu de utopic par exemple ou à rajouter
Partenaires canonical

GIMP + toutes ses options – dessin
Toutes les options de Gedit – texte
chromium – navigation
télécharger: google-chrome – navigation
gufw – Pare-feu firewall
gprename GPRename – rangement
Agave – dessin web
Bluefish + options – html
Gparted – partitionnement
Gimp + options – dessin
Filezilla – FTP
Synaptic + options – ex-logithèque
VLC – vidéos
Libre Office Suite + options – écrire
Speed Crunch – calculatrice
Stellarium – astronomie
Unetbootin – installation de Ubuntu
Gthumb – visionneuse d’images
System Profiler and Benchmark – informations sur le système
Kdenlive – montage vidéo (je ne connais pas mais openshot ne fonctionne pas)
Pitivi – montage vidéo (je ne connais pas mais openshot ne fonctionne pas)
Stopmotion – montage images fixes en vidéo
Recordmydesktop – vidéos du desktop
Règle d’écran – création HTML, mesures en cm et pixels
WebHTTrack – for downloading entire complicated interesting websites

* PDF
Finalement Evince contient Recherche de texte dans son menu, mais je ne l’avais pas vu et il y a aussi Okular qui la contient.
Zathura et faire /texte pour rechercher un texte par exemple /louvre, man zathura pour connaître toutes ses options – visionneur de PDF fonctionnel sous Wily https://pwmt.org/projects/zathura/screenshots/ http://manpages.ubuntu.com/manpages/maverick/man1/zathura.1.html
J’en ai pas besoin et aucune idée si cela marche, il y a
What is new in Master PDF Editor for Mac OS X, Windows and Linux: https://code-industry.net/free-pdf-editor/ FInalement il permet de bien visionner aussi et de rechercher aussi, tout en 1, pas besoin d’installer =D
Mettre aussi : screen capture sur Unity.

* Pepper flash
Pour Chromium (free) et Google-Chrome (non free) c’est :
sudo apt-get install pepperflashplugin-nonfree
Les polices de caractère recommandées pour Firefox et Chromium sont:
sudo apt-get install ttf-dejavu ttf-mscorefonts-installer ttf-xfree86-nonfree gsfonts-x11
Pensez à redémarrer l’ordi après.

* Win pour exécuter les .EXE bien formés et autonomes datant de Win XP
sudo add-apt-repository ppa:ubuntu-wine/ppa; sudo apt-get update; sudo apt-get install wine

* Java c’est intéressant, même s’il est dans les extentions de LibreOffice:
sudo add-apt-repository ppa:webupd8team/java; sudo apt-get update; sudo apt-get install oracle-java8-installer

* Google Earth
sudo apt-get install ttf-mscorefonts-installer qt4-qtconfig
uname -i
file /sbin/init
https://www.google.fr/intl/fr/earth/download/ge/agree.html
sh fichier.deb (il s’ouvre dans la logithèque, pas besoin)

*HPLIP – pilote de mon imprimante, très important
A chaque nouvel Ubuntu et Windows re-télécharger le bon pilote.
http://hplipopensource.com/hplip-web/index.html
sudo chmod -R a+wxr hplip-3.15.11.run
sh hplip-3.15.11.run
L’installation se fait en répondant à des questions sur le terminal.

*Supprimer les pubs
gsettings set com.canonical.Unity.Lenses remote-content-search ‘none’
sudo updatedb; sudo apt-get update; sudo apt-get upgrade; sudo apt-get autoremove; sudo apt-get autoclean
https://fixubuntu.com/
Tweak > Rechercher > Décocher: Montrer + de suggestions
I have nothing against buying Ubuntu related things or buying from Internet or buying applications, but same as for Windows Store, no one needs ads in it, when we search a file, we want a file, not an Add. They should create a separate application with only things and websites to buy things, not an application that sponsors another. Because we only buy when we want, so it’s just unusefull ennoying information.

* Firefox, Chromium et Google-chrome
Adblock Plus, uBlock Origin, HTTPS Everywhere, Pin it (je ne l’utilise pas mais qui sais un jour ?) + Structure fixe et identique et finale du rangement de mes liens + Synchronisation donc aucun besoin de re-installer ni les plugins/add-ons ni les thèmes ad vitam eternam.

*PhpMyAdmin (le seul truc que je connais en informatique et que j’utilise pour réfléchir)
sudo apt-get install lamp-server^
sudo apt-get install php5
sudo apt-get install phpmyadmin
choisir apache2 et exceptionnellement mettre le même mot de passe pour les 3 trucs qu’il demande, l’entrée à défaut se fait avec l’utilisateur: root.
Lire: https://help.ubuntu.com/community/phpMyAdmin
sudo ln -s /usr/share/phpmyadmin/ /var/www/phpmyadmin
sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin.conf
sudo a2enconf phpmyadmin
sudo /etc/init.d/apache2 reload

(I’m not using it now, so later)

* + de Bidules que je n’utilise pas *
*NOT USING THEM BUT INTERESTING:
Skype – tchat par microphone comme si c’était le téléphone, mais je n’utilise pas
Inkskape – dessin vectoriel –
Blender – dessin 3D mais c’est Rhino que je connais
GRASS – géographie mais c’est GIMP et Google Earth que je connais pour la géologie
Praat – phonétique, même si c’est excentré par rapport aux sciences du langage, l’existence d’un tel logiciel de linguistique a longtemps été secrète. Inutile de vous dire que ceux de morphologie et de syntaxe sont encore plus cachés, aucune idée de c’est lesquels ?
R – ça c’était bien car c’est la pratique sans la théorie, et moi j’adore l’art, je suis douée pour la pratique sans la théorie.
Audacity – je n’écoute pas de musique en dehors de la radio, je connais Praat mieux que Audacity, je ne sais pas monter du son. Ceux qui aiment la musique utilisent Amarok.
(je retire du lanceur toutes mes installations uniquement par curiosité)

*Autres bidules*
J’étais en train de voir cette page:
http://www.installer-linux.com/installer-ubuntu-14-04/
Et ça c’est intéressant aussi, la 3D est finalement compatible avec mon ordi sous Wily =D:
/usr/lib/nux/unity_support_test -p
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile
OpenGL version string: 3.0 Mesa 11.0.2

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes

Unity 3D supported: yes

Publicités

Passons à Ubuntu Gnome fin 2015

Par défaut

Je ne suis pas une informaticienne, même si j’ai un double boot, Ubuntu ne doit pas être juste là pour me déconcentrer, donc je vais tester Gnome en espérant que sa capacité d’organisation soit meilleure. Je suis trop dépendante des jeux vidéos et j’ai besoin d’organisation pour m’en sortir, car je veux réaliser encore beaucoup de choses dans ma vie.

sudo apt-get install ubuntu-gnome-desktop

Quote:

Un gestionnaire graphique de session est un programme qui permet de se    │
│ connecter depuis le système X Window.                                     │
│                                                                           │
│ Un seul gestionnaire graphique de session peut s’occuper d’un serveur X   │
│ donné, bien que plusieurs gestionnaires puissent être installés           │
│ simultanément. Veuillez choisir celui qui sera utilisé par défaut.        │
│                                                                           │
│ Plusieurs gestionnaires graphiques peuvent être lancés en même temps,     │
│ s’ils gèrent des serveurs X différents ; pour cela, configurez            │
│ correctement chacun des gestionnaires graphiques, modifiez leurs scripts  │
│ de lancement dans /etc/init.d, et désactivez le test de gestionnaire      │
│ graphique par défaut.

On a le choix entre GDM ou LIGHTDM, mais je ne connais que LIGHTDM donc je le choisis. L’important c’est de s’emmerder un minimum avec l’inconnu. Moi je ne sais que utiliser LIGHTDM c’est la seule raison de mon choix.

Je suis en train de switcher vers GNOME, juste avant la mise à jour de VIVID vers WEREWOLF, donc je commencerais WEREWOLF avec GNOME à la place de UNITY, d’où mes pas sont les suivants:

UNITY+VIVID à GNOME+VIVID à GNOME+WEREWOLF.

sudo service lightdm restart

Là on a switché =) C'est un peu plus sombre, il y a toujours Unity ? 
Mais il y a plein de trucs différents. Et là je vais Upgrader vers Werewolf
en prenant l'action de:
- Désactiver tous les dépôts de la version précédente d'Ubuntu. 
(qui devront être remis en substituant le mot ' vivid ' par le mot ' werewolf '
 dans mon cas)
- Cochant tous les upgrades jusqu'aux backports dans Sources de Logiciels.
- Sélectionnant d'accepter de me prévenir pour chaque nouvelle version.
- Redémarrant.
- Sélectionnant oui pour la mise à niveau. Une fois que tout est stable.

Bye, je vais le faire.

 

Mauvaise idée faut passer à GDM, quote depuis la doc:

Note: Vous pouvez utiliser LightDM avec GNOME Shell, mais dans ce cas vous n’aurez pas l’expérience GNOME 3 complète (par exemple, GNOME Shell n’utilisera pas le nouvel écran de verrouillage de GNOME 3.6).

Si vous aviez déjà GDM installé et qu’on ne vous demande pas de choisir entre LightDM et GDM, ou que vous avez sélectionné LightDM par erreur, vous pouvez entrer la commande suivante dans un terminal :

sudo dpkg-reconfigure gdm

et sélectionner GDM à la place de LightDM.

Donc il faut refaire mes réglages. De plus le terminal plante. Je n’ai pas encore mis à jour le système et la Logithèque devrait avec la mise à niveau être remplacée par Gnome Package Kit: https://help.gnome.org/users/gnome-packagekit/stable/

sudo dpkg-reconfigure gdm
sudo service gdm restart

Finalement je laisse tomber Gnome car ça m'a créé des erreurs sur le disque dur. 
Je vais devoir re-installer Wily en double boot.