Archives de Catégorie: Precise

En passant

0- Comment je login depuis ?

To login:

– Else login is normal but must wait.

– Else login has /tmp error but then is normal.

– Else black screen.

– Still he did not gave me under Precise the Lightdm (lightdm = gdm = terminal mode = etc. each is different but all work alike) login. This is also something you must know how to handle by heart almost blind way. Seen somewhere here and also here. Stop lightdmn, Login + update and upgrade system then start lightdm in terminal mode.

When it does black screen, to login sometimes it is

– CTRL+ALT+DEL during black screen.

– CTRL+ALT+DEL then ENTER ENTER ENTER etc. during black screen.

– Nothing works. Wait some hours then retry.

–  Login in a blind way in my BIOS and launch Ubuntu from live USB version (Menu order of BIOS is preference and was established before my screen went black, so I have blind mind map of last preferences places, so even if you have same PC then me, it won’t be same order. So do not try it if you don’t know it by heart.) : ECH F9 DOWN DOWN ENTER.

–> Then else I can mount hard disk, else I can’t.

–> Else I use USB live, then next time Ubuntu works fine, else I save all my files in /media/my-harddisk-name with: sudo chmod -R a+wxr * then I re-install UBuntu.

Right now I am not re-installing UBuntu no matter it doesn’t work, because I had enough. So else it logs in correctly, else with some trouble, else with some big trouble, else live way. But no more re-installs.

 

I- Installation avec mot de passe au départ et ancienne batterie dedans.

Afin d’empêcher qu’il ne se mette en écran noir après les premiers login.

Suivi de installation des add-ons Mozilla de sécurité: tacos, mask me, better privacy, etc…

Suivi de mise à jour du système Ubuntu et mise à jour des langues (parce que c’est possible sur le mien puisque il ne fait pas l’écran noir tout de suite mais peu après).

Redémarrage.

II- Installation de xerver-xorg-video-intel et xserver-xorg-core à la place de xserver-xorg-video-intel-lts-saucy

Glisser-déposer le terminal. Et lui rajouter plus de mémoire: Edit > File preferences > Scrolling, passer de 512 à 2000.

Je dispose d’un ordinateur portable Intel Pentium dual-core inside, donc avec 2 pilotes intel. Le pilote Ubuntu correspondant est i915. Là un  coeur sur deux est reconnu.

(sudo lshw -c video | grep display) && (sudo lshw -c video | grep configuration)
  *-display:0
  *-display:1 UNCLAIMED
       configuration: driver=i915 latency=0
       configuration: latency=0

 cat /var/log/Xorg.0.log | grep WW
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
 [...]
 [    25.816] (WW) Falling back to old probe method for vesa
 [    25.816] (WW) Falling back to old probe method for modesetting
 [    25.816] (WW) Falling back to old probe method for fbdev

Cette fois-ci on va commencer par s’occuper des 3 dernières mises en garde (warnings), vesa, modesetting et fbdev en installant une version externe du pilote intel (à mon avis il y existe aussi une version de Ubuntu, mais je n’ai pas essayé, accessible depuis Synaptic).

Cette version de Xorg vient déjà avec le pilote intel mentionné et les polices de caractère (à installer ensuite) mentionnées, mais le créer 1 fois suffit car xorg.conf.new ne retient pas nos changements postérieurs.

Il est très important et de connaître les pilotes de remplacement possible, là comme c’est un pilote externe, on les voit listés ici: https://launchpad.net/~glasen/+archive/intel-driver et de connaître les pilotes qui sont installés sur votre ordinateur. Installez Synaptic pour les voir. Mais vous pouvez aussi les voir ainsi:

sudo apt-get install apt-show-versions
(apt-show-versions -r xorg | grep core) && (apt-show-versions -r xorg | grep video-intel)
 xorg-docs-core/precise uptodate 1:1.6-1ubuntu2
 xserver-xorg-core-lts-saucy/precise-updates uptodate 2:1.14.5-1ubuntu2~saucy1~precise2
 xserver-xorg-video-intel-lts-saucy/precise-updates uptodate 2:2.99.904-0ubuntu2.1~precise1

Synaptic c’est intéressant au cas où vous voudriez faire le point sur vos problèmes ou re-installer un paquet, option qui n’existe pas sur le terminal.

sudo apt-get install synaptic

Dans synaptic la version de xserver-xorg-video-intel est: 2:2.17.0-1ubuntu4.4 et dans le PPA Intel graphics driver, la version est: 2:2.21.15~precise~ppa1.1  donc on a le choix entre les 2 même si je vais prendre celui du PPA.

Pour voir la version d’un paquet déjà installé c’est : apt-show-versions -r <Nom du paquet> | grep <Suite du nom du paquet>

Pour voir la version d’un paquet non installé mais présent dans les dépôts c’est : apt-cache show <Nom du paquet> | grep Version

Pour voir la version d’un paquet non installé d’un PPA, regarder la page web du PPA, souvent Launchpad mais pas toujours.

Pour toutes les prochaines explicatiions, tenez compte que là où il faut mettre un double tiret – + – qui n’apparaît pas sur WordPress qui ne fait pas une retranscription fiable des tirets ni des guillemets ni de certains signes de ponctuation et espaces qu’il transforme.

a) Importation du PPA et de sa clé publique qui permet sa mise à jour

 sudo apt-add-repository ppa:glasen/intel-drive

b)  Mise à jour des dépôts de votre Ubuntu (avec Synaptic et Sources de logiciels fermés parce que il n’est pas possible d’installer 2 logiciels au même temps sur un système Linux même si ce fait n’est plus visible puisque auto-géré depuis environ Precise)

sudo apt-get update

c) Une sorte de upgrade du système d’exploitation (modernisation) mais sans changer de version. (Aujourd’hui il n’a que fait le upgrade de libcairo-gobject2 et libcairo2). A ne faire qu’une fois dans ce cadre-là de changement de pilote intel.

sudo apt-get -o Dpkg::Options::="--force-overwrite" dist-upgrade

d) Enlever l’ancien pilote et son noyau xorg associé et les remplacer par les nouveaux. Les  noms de pilotes sont des variables qui pourraient changer de nom au cours du temps.

 Là il faut mettre un double tiret – + – qui n’apparaît pas sur WordPress qui ne fait pas une retranscription fiable des tirets ni des guillemets ni de certains signes de ponctuation et espaces qu’il transforme.

sudo apt-get remove --purge xserver-xorg-video-intel-lts-saucy
sudo apt-get install xserver-xorg-core xserver-xorg-video-intel
sudo dpkg-reconfigure xserver-xorg-core
sudo dpkg-reconfigure xserver-xorg-video-intel

Là faut pas encore éteindre et faut imprimer cela:

Menu flottant > Comptes Utilisateurs > Mot de passe temporaire sans majuscules
 Ctrl-Alt-F1 (or F2, F3 etc.)
 Login: username
 Password: *****
 sudo service lightdm stop
 sudo X -configure
 sudo Xorg -configure
 sudo cp ~/xorg.conf.new /etc/X11/xorg.conf
 sudo service lightdm start

Note: On pourra par la suite (là il me semble que cela fonctionne ainsi), mettre Xorg à jour par lightdm (ou son futur remplaçant) pour qu’il nous dise ses préférences retenues.  Ce que ces lignes font c’est créer xorg.conf  » à partir de rien « , avec la bonne feuille à remplir. Sinon vous n’avez pas xorg.conf.

Le mot de passe temporaire sans majuscules n’est pas obligatoire si vous arrivez à taper les majuscules et les chiffres à l’aveugle.

Là il se peut aussi que les erreurs de dmesg que je n’ai pas encore traitées vous gênent, donc il faut taper rapidement.

sudo gedit /etc/X11/xorg.conf

Xorg a été correctement configuré sans notre aide. Automatique 🙂 Je ne sais pas si c’est une propriété de ce PPA, mais ça nous donne plus de temps libre.

III- Personnalisation et correction des autres problèmes du système

Maintenant il faut personnaliser notre système d’exploitation et corriger ses autres problèmes.

– Affichages (fr) / Displays (en)

– les polices X11 manquantes (fr) / missing X11 fonts (en)

– le Grub

– la 3D et la luminosité / backlight

– les messages d’erreur / dmesg

a) L’affichage

Aller dans le Dash home / Menu et rechercher: Affichages (fr) / Displays (en)

b)  Les polices manquantes

cat /var/log/Xorg.0.log | grep WW
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    19.430] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    19.430] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    19.430] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    19.431] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    19.431] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    19.431] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[... x2 parce qu'il a détecté que j'avais 2 intel]
[    19.431] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    19.431] (WW) Disabling Mouse0
[    19.431] (WW) Disabling Keyboard0
sudo apt-get install xfonts-cyrillic xfonts-100dpi xfonts-75dpi x-ttcidfont-conf defoma defoma-doc libfont-freetype-perl
cd /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType
sudo mkfontdir
ls
sudo apt-get update; sudo apt-get upgrade

Redémarrage pour voir les changements.

 cat /var/log/Xorg.0.log | grep WW
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
 [  2602.375] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
 [  2602.375] (WW) Disabling Mouse0
 [  2602.375] (WW) Disabling Keyboard0

D’après:
http://www.tldp.org/HOWTO/archived/FDU/x-config.html
« If you’ve ever used Netscape or any other program that displays titles using big fonts, you might have noticed that those fonts were pixelized. This is ugly and needs to be corrected. So add :unscaled to the ends of the misc, 100dpi and 75dpi fonts. You can even use both unscaled and scaled fonts if you want, just put the unscaled FontPath lines first to tell X you prefer unscaled fonts if possible. »

Donc:

FontPath « /usr/share/fonts/X11/100dpi/:unscaled »
FontPath « /usr/share/fonts/X11/75dpi/:unscaled »

Dans Xorg.conf c’est normal et même bien.

 

c) Le Grub

On va et mettre le support kms avec i915.modeset=1 et supprimer l’erreur de GRUB_HIDDEN_TIMEOUT en remplaçant GRUB_HIDDEN_TIMEOUT par GRUB_TIMEOUT_STYLE, où on peut mettre hidden ou countdown et en mettant une valeur en secondes à GRUB_TIMEOUT .

sudo update-grub
 Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
 [...]
 done
sudo gedit /etc/default/grub
 GRUB_DEFAULT=0
 GRUB_TIMEOUT_STYLE=hidden
 GRUB_TIMEOUT=6
 GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
 GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1"
 GRUB_CMDLINE_LINUX=""
sudo update-grub

Alors là plus d’erreur.

grep -i i915 /boot/config-`uname -r`
CONFIG_DRM_I915=m
CONFIG_DRM_I915_KMS=y
CONFIG_SND_HDA_I915=y

Montre que le kms est activé.

 

d)  Les erreurs d’accélération

cat /var/log/Xorg.0.log | grep SNA
 (Rien avec ce pilote-ci, ce qui ne veut pas dire qu'on ne peut pas la choisir, l'accélération c'est un choix.)
cat /var/log/Xorg.0.log | grep EE
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
 [   144.830] (II) Loading extension MIT-SCREEN-SAVER
 [   145.282] (EE) AIGLX error: dlopen of /usr/lib/i386-linux-gnu/dri/i965_dri.so failed (/usr/lib/i386-linux-gnu/dri/i965_dri.so: cannot open shared object file: No such file or directory)
 [   145.282] (EE) AIGLX: reverting to software rendering
 [   145.282] (EE) AIGLX error: dlopen of /usr/lib/i386-linux-gnu/dri/swrast_dri.so failed (/usr/lib/i386-linux-gnu/dri/swrast_dri.so: cannot open shared object file: No such file or directory)
 [   145.282] (EE) GLX: could not load software renderer

Donc il y a des erreurs. De plus l’accélération en cours est uxa mais plus sna, par contre on peut remettre sna qui est plus rapide et plus moderne.

(cat /var/log/Xorg.0.log | grep -ie uxa) && (cat /var/log/Xorg.0.log | grep -ie sna)
 [   145.170] (II) UXA(0): Driver registered support for the following operations:
cat /var/log/Xorg.0.log | grep -A 6 UXA
 [   145.170] (II) UXA(0): Driver registered support for the following operations:
 [   145.170] (II)         solid
 [   145.170] (II)         copy
 [   145.170] (II)         composite (RENDER acceleration)
 [   145.170] (II)         put_image
 [   145.170] (II)         get_image
 [   145.170] (==) intel(0): Backing store disabled

On va commencer par mettre uxa en décommentant et changeant la ligne 2 fois de suite car 2 intel dans le mien, on mettra sna plus tard.

sudo gedit /etc/X11/xorg.conf
Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"                # [<bool>]
        Option     "AccelMethod"              "uxa"
etc.
    Identifier  "Card0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
EndSectio
 sudo apt-get -o Dpkg::Options::="--force-overwrite" install libgl1-mesa-dri:i386

Redémarrer. Je n’ai pas chercher quel est le rapport entre libgl1-mesa-dri:i386 et (EE) AIGLX error, mais ça marche. Il existe d’autres propositions de résolution sur le web.

(cat /var/log/Xorg.0.log | grep -ie uxa) && (cat /var/log/Xorg.0.log | grep -ie sna)
 [    21.009] (**) intel(0): Option "AccelMethod" "uxa"
 [    21.581] (II) UXA(0): Driver registered support for the following operations:
cat /var/log/Xorg.0.log | grep EE
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
 [    20.759] (II) Loading extension MIT-SCREEN-SAVER

Plus tard on a essayé avec sna, mais je préfère laisser uxa vu que mon ordinateur est vieux et fait des stries sur compiz.

e) La 3D et la luminosité (en cours) (ce  n’est pas résolu)

On va essayer d’installer la 3D avant la luminosité, juste pour voir si c’est lié. (dans mon essai c’est après)

La 3D avec Freeglut3 et Glew

sudo apt-get install freeglut3 build-essential g++ cmake mesa-utils glew-utils libglew1.6

paquets suggérés: sudo apt-get install debian-keyring g++-multilib g++-4.6-multilib gcc-4.6-doc libstdc++6-4.6-dbg
  libstdc++6-4.6-doc (également installés)

grep rendering /var/log/Xorg.0.log

[ 1046.060] (II) intel(0): direct rendering: DRI2 Enabled

glxinfo | grep direct

direct rendering: Yes

La 3D avec Glee

wget -q -O - http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -
sudo sh -c 'echo "deb http://archive.getdeb.net/ubuntu precise-getdeb apps" >> /etc/apt/sources.list.d/getdeb.list'
sudo sh -c 'echo "deb http://archive.getdeb.net/ubuntu lucid-getdeb games" >> /etc/apt/sources.list.d/getdeb.list'
sudo apt-get update
sudo apt-get install glee-dev

Là glee-dev est dans Games, mais on va aussi suggérer les logiciels 3D supplémentaires qui vont avec.

Les PPA contiennent des listes de programmes à télécharger. Si jamais l'un d'entre eux est trop long, vous le commentez alors ses programmes à télécharger ne seront plus disponibles. Vous pouvez aussi commenter le code source des programmes.
Ils peuvent être dans: Software Sources
ou dans:
sudo gedit /etc/apt/sources.list   
#Commenter = #désactiver / décommenter = activer
sudo apt-get update; sudo apt-get upgrade

Pour la luminosité rien ne marche.

Aller sur l’icône Batterie/énergie/power settings/brightness:
– Ne pas mettre en veille si inactif sur batterie ni quand le câble est branché. (Don’t suspend when inactive)
– Lorsque l’écran est fermé, ne rien faire. (When lid is closed do nothing)
– Ne jamais afficher le statut de la batterie. (Never show battery status in the menu bar.)
Brightness settings:
– Luminosité: augmenter (l’option ne reste pas).
– Eteindre l’écran si inactif depuis 10 min. (Turn screen off when inactive for 10min)
– Verrouiller l’écran après 30min. (Lock on – Lock screen after 30min)
– (Require my password when waiting for suspend)

Puis voir quel est votre pilote de luminosité:

ls /sys/class/backlight/

acpi_video0

L’idée de Ubuntu c’est de remplacer acpi_video0 par intel_backlight ce qui ne marche pas et fait tout disparaître donc peu importe ce qu’on essaye rien ne marche.

On va changer uxa pour sna et mettre acpi_video0 au lieu de intel_backlight en espérant que ça revienne.

sudo gedit /etc/X11/xorg.conf
Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"                # [<bool>]
        Option     "AccelMethod"            "sna"
        Option     "Backlight"              "acpi_video0"
etc...

x2

Et on va retirer la tentative de mettre acpi_backlight=vendor pour avoir intel_backlight qui chez moi ne s’active pas du tout.

sudo gedit /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1 acpi_osi=Linux video.use_native_backlight=1"
 sudo update-grub; sudo update-initramfs -u

(Je ne sais pas pourquoi j’ai mis les deux commandes.)

Avant j’avais l’erreur suivante quand j’avais testé avec intel_backlight au travers le Grub (acpi_backlight=vendor) et xorg.conf (Devices):

cat /var/log/Xorg.0.log | grep EE
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    23.136] (EE) intel(0): unrecognised backlight control interface intel_backlight

Maintenant c’est revenu au problème d’avant. Où j’avais déjà installé: sudo apt-get install xbacklight

cat /var/log/Xorg.0.log | grep EE
 (pas d'erreur)
cat /var/log/Xorg.0.log | grep SNA
 [ 23.624] (II) intel(0): SNA initialized with Eaglelake (gen4.5) backend
xbacklight -get
 0.000000
sudo nano /sys/class/backlight/acpi_video0/brightness
9
CTRL+O pour écrire puis enter puis CTRL+X pour sauver.
xbacklight -get 90.000000 

Là ça ne marchera que pour une session pour pour l'icône de luminosité ou alors il faudra 
l'ajouter au démarrage à /etc/rc.local mais faudra demander de l'aide pour le faire.

Non résolu.

———————————————————————————————————————————————————–

f)  Les erreurs de dmesg

On a l’erreur EDID checksum qui est sûrement liée à l’erreur « Number of created screens does not match number of detected devices » lors de la création de xorg.conf dans lightdm (ou équivalent).

dmesg | grep EDID | head -1
[    9.932080] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 21

xrandr -q
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
LVDS1 connected (normal left inverted right x axis y axis)
1024×768 60.0 +
800×600 60.3 56.2
640×480 59.9
VGA1 connected 1366×768+0+0 (normal left inverted right x axis y axis) 409mm x 230mm
1366×768 59.8*+
1280×1024 75.0 60.0
1280×960 60.0
1280×800 59.8
1152×864 75.0
1280×720 60.0
1024×768 75.1 70.1 60.0
832×624 74.6
800×600 72.2 75.0 60.3 56.2
640×480 75.0 72.8 66.7 60.0
720×400 70.1
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
TV1 disconnected (normal left inverted right x axis y axis)

+0+0 c’est l’erreur de Edid.

xrandr -r 70
Rate 70.0 Hz not available for this size

xrandr -r 60
(OK)

cvt 1366 768 60
# 1368×768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz
Modeline « 1368x768_60.00 » 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync

xrandr –newmode « 1368x768_60.00 » 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync

(en cours de réflexion)

Egalement installé:  sudo apt-get install read-edid edid-decode

Où on peut lire le nom des moniteurs: sudo get-edid | parse-edid

Non résolu.

dmesg | grep -i failed | head -2
[   55.316900] sd 0:0:0:0: [sdb] Test WP failed, assume Write Enabled
[   55.319277] sd 0:0:0:0: [sdb] Asking for cache data failed

Il s’agit de votre lecteur de carte SD, donc on ne va pas retirer le pilote.

sudo gedit /etc/X11/xorg.conf
Add section:
Section "ServerFlags"
  Option "AllowEmptyInput" "False"
EndSection

On peut aussi enlever et remettre le même pilote:
sudo rmmod ums_realtek
sudo sh -c 'echo "options ums_realtek ss_en=0" > /etc/modprobe.d/ums-realtek.conf'
echo "ums-realtek ss_en=0" |sudo tee -a /etc/modules
sudo modprobe ums_realtek
Redémarrer et essayer de mettre la carte SD. 

La carte SD marche mais l'erreur est toujours là.
La dernière fois ça avait marché. Peut-être avec le temps?
Je vais laisser comme cela. 
Quelques erreurs par-ci, par là c'est pas grave.

Non résolu.

 

intel black screen old laptop version 2 Precise

intel black screen old laptop version 1 Precise

Par défaut

Please see version 2:  intel black screen old laptop version 2 Precise

S’il vous plaît allez sur la version 2: intel black screen old laptop version 2 Precise

======================= Old / Périmé ===========================================

Trying to solve problem without knowing if problem is xorg, battery, intel, compiz, external monitor, kernel … ?

Test in solving black screen in an old intel vga laptop

Fresh install 🙂 avec un mot de passe au démarrage et avec la batterie (je l’ai remise 3ans après ou +) qui ne marche pas et avec mon écran externe sur l’ordi portable Presario CQ70.

sudo lshw -c video

*-display:0
description: VGA compatible controller
produit: Mobile 4 Series Chipset Integrated Graphics Controller
fabriquant: Intel Corporation
identifiant matériel: 2
information bus: pci@0000:00:02.0
version: 07
bits: 64 bits
horloge: 33MHz
fonctionnalités: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
ressources: irq:44 mémoire:90000000-903fffff mémoire:80000000-8fffffff portE/S:5110(taille=8)
*-display:1 NON-RÉCLAMÉ
description: Display controller
produit: Mobile 4 Series Chipset Integrated Graphics Controller
fabriquant: Intel Corporation
identifiant matériel: 2.1
information bus: pci@0000:00:02.1
version: 07
bits: 64 bits
horloge: 33MHz
fonctionnalités: pm bus_master cap_list
configuration: latency=0
ressources: mémoire:92500000-925fffff

 

sudo apt-get install apt-show-versions

apt-show-versions -r xorg
xorg 1:7.6+12ubuntu2 newer than version in archive
xorg-docs-core/precise uptodate 1:1.6-1ubuntu2
xserver-xorg-core-lts-saucy/precise uptodate 2:1.14.5-1ubuntu2~saucy1~precise2
xserver-xorg-glamoregl-lts-saucy/precise uptodate 0.5.1-0ubuntu4.2~precise2
xserver-xorg-input-all-lts-saucy/precise uptodate 1:7.7+1ubuntu6~precise1
xserver-xorg-input-evdev-lts-saucy/precise uptodate 1:2.7.3-0ubuntu3.1~precise1
xserver-xorg-input-mouse-lts-saucy/precise uptodate 1:1.7.2-3build1~precise1
xserver-xorg-input-synaptics-lts-saucy/precise uptodate 1.7.1-0ubuntu1~precise1
xserver-xorg-input-vmmouse-lts-saucy/precise uptodate 1:12.9.0-0ubuntu4~precise1
xserver-xorg-input-wacom-lts-saucy/precise uptodate 1:0.20.0-0ubuntu1~precise1
xserver-xorg-lts-saucy/precise uptodate 1:7.7+1ubuntu6~precise1
xserver-xorg-video-all-lts-saucy/precise uptodate 1:7.7+1ubuntu6~precise1
xserver-xorg-video-ati-lts-saucy/precise uptodate 1:7.2.0-0ubuntu10~precise2
xserver-xorg-video-cirrus-lts-saucy/precise uptodate 1:1.5.2-0ubuntu2~precise1
xserver-xorg-video-fbdev-lts-saucy/precise uptodate 1:0.4.3-0ubuntu3~precise1
xserver-xorg-video-intel-lts-saucy/precise uptodate 2:2.99.904-0ubuntu2.1~precise1
xserver-xorg-video-mach64-lts-saucy/precise uptodate 6.9.3-0ubuntu3~precise1
xserver-xorg-video-mga-lts-saucy/precise uptodate 1:1.6.2-0ubuntu2~precise1
xserver-xorg-video-modesetting-lts-saucy/precise uptodate 0.8.0-0ubuntu1.1~precise1
xserver-xorg-video-neomagic-lts-saucy/precise uptodate 1:1.2.7-0ubuntu3~precise1
xserver-xorg-video-nouveau-lts-saucy/precise uptodate 1:1.0.9-2ubuntu1~precise2
xserver-xorg-video-openchrome-lts-saucy/precise uptodate 1:0.3.1-0ubuntu2.1~precise1
xserver-xorg-video-r128-lts-saucy/precise uptodate 6.9.1-0ubuntu2~precise1
xserver-xorg-video-radeon-lts-saucy/precise uptodate 1:7.2.0-0ubuntu10~precise2
xserver-xorg-video-s3-lts-saucy/precise uptodate 1:0.6.5-0ubuntu3.1~precise1
xserver-xorg-video-savage-lts-saucy/precise uptodate 1:2.3.6-0ubuntu3~precise1
xserver-xorg-video-siliconmotion-lts-saucy/precise uptodate 1:1.7.7-0ubuntu3~precise1
xserver-xorg-video-sis-lts-saucy/precise uptodate 1:0.10.7-0ubuntu4~precise1
xserver-xorg-video-sisusb-lts-saucy/precise uptodate 1:0.9.6-0ubuntu3~precise1
xserver-xorg-video-tdfx-lts-saucy/precise uptodate 1:1.4.5-0ubuntu3~precise1
xserver-xorg-video-trident-lts-saucy/precise uptodate 1:1.3.6-0ubuntu4~precise1
xserver-xorg-video-vesa-lts-saucy/precise uptodate 1:2.3.2-0ubuntu3~precise1
xserver-xorg-video-vmware-lts-saucy/precise uptodate 1:13.0.1-0ubuntu2~precise1


dpkg --status xserver-xorg-video-intel-lts-saucy | head -5
Package: xserver-xorg-video-intel-lts-saucy
Status: install ok installed
Priority: optional
Section: x11
Installed-Size: 2660


 dpkg --status xserver-xorg-video-openchrome-lts-saucy | head -5
Package: xserver-xorg-video-openchrome-lts-saucy
Status: install ok installed
Priority: optional
Section: x11
Installed-Size: 522

Premier constat trop de drivers installés.


sudo lshw -html > systeme.html
firefox systeme.html


 sudo lshw | grep driver
          configuration: driver=agpgart-intel
             configuration: driver=i915 latency=0
             configuration: driver=uhci_hcd latency=0
             configuration: driver=uhci_hcd latency=0
             configuration: driver=uhci_hcd latency=0
             configuration: driver=ehci-pci latency=0
             configuration: driver=snd_hda_intel latency=0
             configuration: driver=pcieport
                configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.0.12 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
             configuration: driver=pcieport
                configuration: broadcast=yes driver=ath5k driverversion=3.11.0-15-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bg
             configuration: driver=uhci_hcd latency=0
             configuration: driver=uhci_hcd latency=0
             configuration: driver=uhci_hcd latency=0
             configuration: driver=ehci-pci latency=0
             configuration: driver=lpc_ich latency=0
             configuration: driver=ahci latency=0
          configuration: driver=usb-storage

sudo apt-get install synaptic

Aller sur synaptic, laisser:
xserver-xorg-video- intel-lts-saucy et vesa-lts-saucy et fbdev-lts-saucy et modesetting-lts-saucy
Mais,
xserver-xorg-video-all-lts-saucy sera désinstallé
xserver-xorg-video-ati-lts-saucy sera désinstallé
xserver-xorg-video-cirrus-lts-saucy sera désinstallé
xserver-xorg-video-mach64-lts-saucy sera désinstallé
xserver-xorg-video-mga-lts-saucy sera désinstallé
xserver-xorg-video-neomagic-lts-saucy sera désinstallé
xserver-xorg-video-nouveau-lts-saucy sera désinstallé
xserver-xorg-video-openchrome-lts-saucy sera désinstallé
xserver-xorg-video-r128-lts-saucy sera désinstallé
xserver-xorg-video-radeon-lts-saucy sera désinstallé
xserver-xorg-video-s3-lts-saucy sera désinstallé
xserver-xorg-video-savage-lts-saucy sera désinstallé
xserver-xorg-video-siliconmotion-lts-saucy sera désinstallé
xserver-xorg-video-sis-lts-saucy sera désinstallé
xserver-xorg-video-sisusb-lts-saucy sera désinstallé
xserver-xorg-video-tdfx-lts-saucy sera désinstallé
xserver-xorg-video-trident-lts-saucy sera désinstallé
xserver-xorg-video-vmware-lts-saucy sera désinstallé

D'après Synaptic, xserver-xorg-video-intel tout court ne peut être installé parce qu'il manque 
un dépôt avec des dépendances.
xserver-xorg-video-intel:
 Dépend: xorg-video-abi-11
 Dépend: xserver-xorg-core (>= 2:1.10.99.901)

Cependant d'après Synaptic si j'installais xserver-xorg-core, je désinstallerai tous les lts-saucy.

Donc c'est peut-être pas ça.

sudo updatedb

 cat /proc/bus/input/devices | grep N:
N: Name="Lid Switch"
N: Name="Sleep Button"
N: Name="Power Button"
S: Sysfs=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
N: Name="AT Translated Set 2 keyboard"
N: Name="HP WMI hotkeys"
N: Name="SynPS/2 Synaptics TouchPad"
N: Name="CNF7047"
N: Name="Video Bus"
N: Name="HDA Intel HDMI/DP,pcm=3"

 (lsusb | grep -i Synaptics) || (dmesg | grep -i Synaptics)
[   12.415162] psmouse serio2: synaptics: Touchpad model: 1, fw: 7.0, id: 0x1a0b1, caps: 0xd04711/0xa00000/0x20000, board id: 3655, fw id: 502777
[   12.478629] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio2/input/input5

Au moins désinstaller ceux-là via Synaptics certainement:
xserver-xorg-input-all-lts-saucy sera désinstallé
xserver-xorg-input-vmmouse-lts-saucy sera désinstallé
xserver-xorg-input-wacom-lts-saucy sera désinstallé

sudo updatedb

apt-show-versions -r xorg (plus tard)
cat /var/log/Xorg.0.log | grep WW
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    25.265] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    25.265] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    25.265] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    25.265] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    25.265] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    26.263] (WW) Falling back to old probe method for vesa
[    26.263] (WW) Falling back to old probe method for modesetting
[    26.263] (WW) Falling back to old probe method for fbdev


sudo apt-get install xfonts-cyrillic xfonts-100dpi xfonts-75dpi x-ttcidfont-conf defoma defoma-doc libfont-freetype-perl

cd /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType

sudo mkfontdir

ls

sudo apt-get update; sudo apt-get upgrade

Redémarrer  (plante pas stp !!!!!!!!!)
 cat /var/log/Xorg.0.log | grep WW    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    22.732] (WW) Falling back to old probe method for vesa
[    22.732] (WW) Falling back to old probe method for modesetting
[    22.732] (WW) Falling back to old probe method for fbdev
Alors toujours avant d'installer glasen, plus d'essais:
dmesg | grep EDID | head -1
[   10.388038] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 244

sudo gedit /etc/default/grub 
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1"

sudo update-grub

dmesg | grep failed | head -4
[   54.800900] sd 0:0:0:0: [sdb] Test WP failed, assume Write Enabled
[   54.803264] sd 0:0:0:0: [sdb] Asking for cache data failed
[  106.512924] sd 0:0:0:0: [sdb] Test WP failed, assume Write Enabled
[  106.515292] sd 0:0:0:0: [sdb] Asking for cache data failed


Ne marche pas avec:

sudo rmmod ums_realtek
sudo sh -c 'echo "options ums_realtek ss_en=0" > /etc/modprobe.d/ums-realtek.conf'
echo "ums-realtek ss_en=0" |sudo tee -a /etc/modules
sudo modprobe ums_realtek

Rem: il s'agit de votre lecteur de carte SD donc laisser le module.  
(Pour plus Cf. sujets: http://askubuntu.com/questions/167343/what-is-a-asking-for-cache-data-failed-warning et 
http://askubuntu.com/questions/132100/errors-in-dmesg-test-wp-failed-assume-write-enabled)

dmesg | grep EDID | head -1
[ 10.116057] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 244

 sudo apt-get install read-edid edid-decode

Mon pilote d'écran externe:
http://www.emachines.fr/ec/fr/FR/content/drivers
(on ne peut rien faire avec un pilote Windows)

sudo get-edid | parse-edid
get-edid: get-edid version 2.0.0

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0
    Function supported
    Call successful

    VBE version 300
    VBE string at 0x2110 "Intel(r)Cantiga Graphics Chip Accelerated VGA BIOS"

VBE/DDC service about to be called
    Report DDC capabilities

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0
    Function supported
    Call successful

    Monitor and video card combination does not support DDC1 transfers
    Monitor and video card combination supports DDC2 transfers
    0 seconds per 128 byte EDID block transfer
    Screen is not blanked during DDC transfer

Reading next EDID block

VBE/DDC service about to be called
    Read EDID

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
    Function supported
    Call successful

parse-edid: EDID checksum passed.

    # EDID version 1 revision 3
Section "Monitor"
    # Block type: 2:0 3:fd
    # Block type: 2:0 3:fc
    Identifier "E190HQV"
    VendorName "EMA"
    ModelName "E190HQV"
    # Block type: 2:0 3:fd
    HorizSync 31-80
    VertRefresh 56-76
    # Max dot clock (video bandwidth) 140 MHz
    # Block type: 2:0 3:fc
    # Block type: 2:0 3:ff
    # DPMS capabilities: Active off:no  Suspend:yes  Standby:yes

    Mode     "1366x768"    # vfreq 59.790Hz, hfreq 47.712kHz
        DotClock    85.500000
        HTimings    1366 1436 1579 1792
        VTimings    768 771 774 798
        Flags    "+HSync" "+VSync"
    EndMode
    # Block type: 2:0 3:fd
    # Block type: 2:0 3:fc
    # Block type: 2:0 3:ff
EndSection

(aucune idée de quoi en faire???)

Alors là sans redémarrage pour le driver intel:


sudo apt-add-repository ppa:glasen/intel-driver

sudo apt-get update

sudo apt-get -o Dpkg::Options::="--force-overwrite" dist-upgrade

(sudo apt-get remove --purge xserver-xorg-video-intel-lts-quantal

sudo apt-get install xserver-xorg-core xserver-xorg-video-intel

sudo dpkg-reconfigure xserver-xorg-core

sudo dpkg-reconfigure xserver-xorg-video-intel) la question c'est si on peut ne pas l'enlever ?

Essayons sans l'enlever.

 cat /var/log/Xorg.0.log | grep -i sna
[    22.483] (II) intel(0): SNA compiled: xserver-xorg-video-intel-lts-saucy 2:2.99.904-0ubuntu2.1~precise1 (Timo Aaltonen <e-mail>)
[    22.565] (II) intel(0): SNA initialized with Eaglelake (gen4.5) backend

Sna est activée et utilise xserver-xorg-video-intel-lts-saucy.

Menu flottant > Comptes Utilisateurs > Mot de passe temporaire sans majuscules
 Ctrl-Alt-F1 (or F2, F3 etc.)
 Login: username
 Password: *****
 sudo service lightdm stop
 sudo X -configure
 sudo Xorg -configure
 sudo cp ~/xorg.conf.new /etc/X11/xorg.conf
 sudo service lightdm start

(ne pas redémarrer tout de suite)
sudo gedit /etc/X11/xorg.conf
Imprimer dans un tableau à 2 colonnes sur LibreOffice pour comprendre. 

On commente cela:
    #Screen      2  "Screen2" RightOf "Screen1"
    #Screen      3  "Screen3" RightOf "Screen2"
    #Screen      4  "Screen4" RightOf "Screen3"
    #Screen      5  "Screen5" RightOf "Screen4"

Et tous ceux-là de 2 à 5:
#Section "Monitor"
    #Identifier   "Monitor5"
    #VendorName   "Monitor Vendor"
    #ModelName    "Monitor Model"
#EndSection

Et tous ceux-là de 2 à 5:
#Section "Screen"
    #Identifier "Screen2"
    #Device     "Card2"
    #Monitor    "Monitor2"
    #SubSection "Display"
        #Viewport   0 0
        #Depth     1
    #EndSubSection
    #SubSection "Display"
        #Viewport   0 0
        #Depth     4
    #EndSubSection
    #SubSection "Display"
        #Viewport   0 0
        #Depth     8
    #EndSubSection
    #SubSection "Display"
        #Viewport   0 0
        #Depth     15
    #EndSubSection
    #SubSection "Display"
        #Viewport   0 0
        #Depth     16
    #EndSubSection
    #SubSection "Display"
        #Viewport   0 0
        #Depth     24
    #EndSubSection
#EndSection
Et on dé-commente cela:
Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"                # [<bool>]
        Option     "AccelMethod"              "sna"
etc.
    Identifier  "Card0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
EndSection


Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"                # [<bool>]
        Option     "AccelMethod"              "sna"
etc.
    Identifier  "Card1"
    Driver      "intel"
    BusID       "PCI:0:2:1"
EndSection


Rem: j'ai un intel Pentium Dual-Core inside donc 2 fois le pilote intel.

Perso, je pense qu'il vaut mieux pas toucher à Monitor puisque j'en ai 2 et je ne sais pas si il passe
 de 0 à 1 facilement pour le nom de Monitor: E190HQV.

Redémarrer en espérant qu'il ne plante pas après tout ce travail !!!!!!!!!


cat /var/log/Xorg.0.log | grep WW
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 27.239] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 27.239] (WW) Disabling Mouse0
[ 27.239] (WW) Disabling Keyboard0

dmesg | grep EDID | head -1
[ 14.820032] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 244

sudo gedit /etc/X11/xorg.conf
Add section:
Section "ServerFlags"
  Option "AllowEmptyInput" "False"
EndSection

sudo apt-get install freeglut3 build-essential g++ cmake mesa-utils glew-utils libglew1.6

paquets suggérés: sudo apt-get install debian-keyring g++-multilib g++-4.6-multilib gcc-4.6-doc libstdc++6-4.6-dbg
  libstdc++6-4.6-doc (également installés)

sudo gedit /etc/X11/xorg.conf
Changez la section:
Section "Module"
    Load  "glx"
    Load  "dri"
EndSection


grep rendering /var/log/Xorg.0.log
[    27.814] (II) intel(0): direct rendering: DRI2 Enabled

glxinfo | grep direct
direct rendering: Yes

sudo sh -c 'echo "deb http://archive.getdeb.net/ubuntu precise-getdeb apps" >> /etc/apt/sources.list.d/getdeb.list'
sudo sh -c 'echo "deb http://archive.getdeb.net/ubuntu precise-getdeb games" >> /etc/apt/sources.list.d/getdeb.list'

sudo apt-get update

sudo apt-get install glee-dev
sudo gedit /etc/apt/sources.list  et Software Sources
Commenté tous les fichiers source.
sudo apt-get update; sudo apt-get upgrade

Rem: l'écran fait des rayures au démarrage, sûrement un problème de compiz, installation des autres paquets
 de compiz:

sudo apt-get install compizconfig-settings-manager compiz-fusion-plugins-extra compiz-fusion-plugins-main compiz-plugins

Choix divers dont Group and Tab Windows, mais juste une option a été annulée de Expo, pas Expo dont Unity en dépend, puis re-démarrages.

Batterie/énergie: Ne pas mettre en veille si inactif sur batterie ni quand le câble est branché.
Lorsque l'écran est fermé, ne rien faire.
Ne jamais afficher le statut de la batterie.
Luminosité: augmenter (l'option ne reste pas).
Eteindre l'écran si inactif depuis 10 min.
Verrouiller l'écran après 30min.


On va essayer celui-là:
sudo apt-get install gconf-editor
sudo gconf-editor 
> apps > backlight (il n'y a pas)
brightness_ac *Sur courant alternatif, valeurs de 0 à 100.
brightness_dim_battery *Sur batterie, valeurs de 0 à 100.
idle_brightness *Lorsque inactif, généralement 30.

ls /sys/class/backlight/acpi_video0/
actual_brightness  brightness  max_brightness  subsystem  uevent
bl_power           device      power           type

cat /sys/class/backlight/acpi_video0/actual_brightness 
0
cat /sys/class/backlight/acpi_video0/brightness
0
cat /sys/class/backlight/acpi_video0/max_brightness 
10
cat /sys/class/backlight/acpi_video0/bl_power
0
cat /sys/class/backlight/acpi_video0/type
firmware


sudo nano /sys/class/backlight/acpi_video0/brightness
9

Rem: Ces suggestions sont là: https://wiki.archlinux.org/index.php/backlight

Ah, luminosité et verrouillage ça a changé.

Ps: pas toucher à bl_power, où apparemment backlight on c'est 0 et off c'est 1.

ls /sys/class/backlight/
acpi_video0


Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"                # [<bool>]
        Option     "AccelMethod"              "sna"
        Option     "Backlight"                "acpi_video0"
        #Option     "DRI"                    # <str>
    Identifier  "Card0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"                # [<bool>]
        Option     "AccelMethod"              "sna"
        Option     "Backlight"                "acpi_video0"
        #Option     "DRI"                    # <str>
    Identifier  "Card1"
    Driver      "intel"
    BusID       "PCI:0:2:1"
EndSection

Attention c'est mon module, le votre peut être un autre.

modprobe -d *
FATAL: Could not load Bureau/lib/modules/3.11.0-19-generic/modules.dep: No such file or directory

uname -r
3.11.0-19-generic

sudo update-initramfs -c -k 3.11.0-19-generic
update-initramfs: Generating /boot/initrd.img-3.11.0-19-generic
D'après: http://www.linuxquestions.org/questions/debian-26/modprobe-fatal-could-not-load-lib-modules-modules-dep-335214/

Je ne sais pas le charger.
lsmod

modinfo i915 | grep filename
filename:       /lib/modules/3.11.0-19-generic/kernel/drivers/gpu/drm/i915/i915.ko

locate modules.dep
/lib/modules/3.11.0-15-generic/modules.dep
/lib/modules/3.11.0-15-generic/modules.dep.bin
/usr/share/man/man5/modules.dep.5.gz
/usr/share/man/man5/modules.dep.bin.5.gz


modprobe -d *
FATAL: Could not load bin/lib/modules/3.11.0-19-generic/modules.dep: No such file or directory

Non résolu (en haut).

sudo update-grub
Generating grub.cfg …
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-3.11.0-19-generic
Found initrd image: /boot/initrd.img-3.11.0-19-generic
Found linux image: /boot/vmlinuz-3.11.0-15-generic
Found initrd image: /boot/initrd.img-3.11.0-15-generic
Found memtest86+ image: /boot/memtest86+.bin
done

sudo gedit /etc/default/grub
GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=countdown
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT= »quiet splash i915.modeset=1″
GRUB_CMDLINE_LINUX= » »

sudo update-grub
Generating grub.cfg …
Found linux image: /boot/vmlinuz-3.11.0-19-generic
Found initrd image: /boot/initrd.img-3.11.0-19-generic
Found linux image: /boot/vmlinuz-3.11.0-15-generic
Found initrd image: /boot/initrd.img-3.11.0-15-generic
Found memtest86+ image: /boot/memtest86+.bin
done

 

modprobe -d *
FATAL: Could not load Bureau/lib/modules/3.11.0-19-generic/modules.dep: No such file or directory
Synaptic:
module-init-tools (version 3.16-1ubuntu2) sera réinstallé

lsmod (copier)

modprobe btrfs
lsmod | grep btrfs
modprobe raid6_pq
modprobe zlib_deflate 
modprobe xor
modprobe ufs
modprobe qnx4

Là je demande, je suis larguée.

============

Ce matin c'était:
1er redémarrage: écran noir
2ème redémarrage: Ubuntu smile smile smile + 1 erreur

Le disque dur /tmp n'est pas encore prêt ou présent.
cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sdc1 during installation
UUID=3ee8b084-92f7-4def-a31a-b604e25519cc /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdc5 during installation
UUID=499aa89b-1419-4a49-9ff1-8fb8fffc8473 none            swap    sw              0       0
ls -ld /tmp
drwxrwxrwt 11 root root 4096 avril  2 07:59 /tmp
grep -w /tmp /etc/mtab

sudo gedit /etc/default/grub
GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=6
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1"
GRUB_CMDLINE_LINUX=""

sudo update-grub

 ===============

Ordi qui marche 1 fois sur deux, j’ai forcément oublié quelque chose.

Etats des lieux, non publié sur Launchpad:

Hello, yes I had put back battery that I had taken out 3years ago.

But each time, from 10 last times, I turn computer on, 1st time it turns on: black screen, 2nd time I turn it on: it works but sometimes with /tmp error (The disk drive for /tmp is not ready). So perhaps my problem could be PC dying ?

Well I can’t do better than what I had said I did in my blog: intel ppa glasen + a lot of changing. https://memubuntu.wordpress.com/2014/04/01/intel-black-screen-old-laptop/

………… I forgot to install or xserver-xorg-video-intel-lts-quantal or  xserver-xorg-video-intel  from Glasen PPA. I thought installing the PPA was enough. And I’ll uninstall xserver-xorg-video-intel-lts-saucy.

——–

About what concerns versions:
apt-show-versions gnome-power-manager
gnome-power-manager 3.4.0-0ubuntu1.1 newer than version in archive

dpkg –status gnome-power-manager | head -5
Package: gnome-power-manager
Status: install ok installed
Priority: optional
Section: gnome
Installed-Size: 1584

ls /sys/class/backlight/
acpi_video0

I also have kept:
apt-show-versions -r xorg
xorg 1:7.6+12ubuntu2 newer than version in archive
xorg-docs-core/precise uptodate 1:1.6-1ubuntu2
xserver-xorg-core-lts-saucy/precise uptodate 2:1.14.5-1ubuntu2~saucy1~precise2
xserver-xorg-input-evdev-lts-saucy/precise uptodate 1:2.7.3-0ubuntu3.1~precise1
xserver-xorg-input-mouse-lts-saucy/precise uptodate 1:1.7.2-3build1~precise1
xserver-xorg-input-synaptics-lts-saucy/precise uptodate 1.7.1-0ubuntu1~precise1
xserver-xorg-lts-saucy/precise uptodate 1:7.7+1ubuntu6~precise1
xserver-xorg-video-fbdev-lts-saucy/precise uptodate 1:0.4.3-0ubuntu3~precise1
xserver-xorg-video-intel-lts-saucy/precise uptodate 2:2.99.904-0ubuntu2.1~precise1
xserver-xorg-video-modesetting-lts-saucy/precise uptodate 0.8.0-0ubuntu1.1~precise1
xserver-xorg-video-vesa-lts-saucy/precise uptodate 1:2.3.2-0ubuntu3~precise1

cat /var/log/Xorg.0.log | grep -i sna
[    23.628] (II) intel(0): SNA compiled: xserver-xorg-video-intel-lts-saucy 2:2.99.904-0ubuntu2.1~precise1 (Timo Aaltonen <tjaalton@ubuntu.com>)
[    23.725] (**) intel(0): Option « AccelMethod » « sna »
[    23.923] (II) intel(0): SNA initialized with Eaglelake (gen4.5) backend

modprobe -d *
FATAL: Module C:\nppdf32Log\debuglog.txt not found.
modprobe -d -v *
FATAL: Could not load -v/lib/modules/3.11.0-19-generic/modules.dep: No such file or directory

cat /var/log/Xorg.0.log | grep WW
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    23.140] (WW) Hotplugging is on, devices using drivers ‘kbd’, ‘mouse’ or ‘vmmouse’ will be disabled.
[    23.140] (WW) Disabling Mouse0
[    23.140] (WW) Disabling Keyboard0

dmesg | grep EDID | head -1
[   10.268040] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 21

dmesg | grep failed | head -4

======================================

Choix à faire:

http://ppa.launchpad.net/glasen/intel-driver/ubuntu/dists/precise/main/binary-i386/Packages

 

Package: xserver-xorg-video-intel
Priority: optional
Section: x11
Installed-Size: 1457
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: i386
Version: 2:2.21.15~precise~ppa1.1
Recommends: intel-gpu-tools
Replaces: xserver-xorg (<< 6.8.2-35), xserver-xorg-driver-i810, xserver-xorg-video-i810 (<< 2:1.9.91-1), xserver-xorg-video-i810-modesetting, xserver-xorg-video-intel-modesetting
Provides: xorg-driver-video, xserver-xorg-video-
Depends: libc6 (>= 2.15), libdrm-intel1 (>= 2.4.29), libdrm2 (>= 2.4.30), libpciaccess0 (>= 0.8.0+git20071002), libpixman-1-0 (>= 0.21.6), libudev0 (>= 147), xorg-video-abi-11, xserver-xorg-core (>= 2:1.10.99.901)
Conflicts: 915resolution, xserver-xorg-driver-i810, xserver-xorg-video-i810 (<< 2:1.9.91-1), xserver-xorg-video-i810-modesetting, xserver-xorg-video-intel-modesetting
Filename: pool/main/x/xserver-xorg-video-intel/xserver-xorg-video-intel_2.21.15~precise~ppa1.1_i386.deb
Size: 634396
MD5sum: 7733dac556cd2f1d843e354e54a99421
SHA1: bc496417177de40d2869d7458930f23c99f65ead
SHA256: 5d9f0a6eea97d3a192515bb47aacc2143da00fe830848735702f77e8249814e4
Description: X.Org X server -- Intel i8xx, i9xx display driver
 This package provides the driver for the Intel i8xx and i9xx family
 of chipsets, including i810, i815, i830, i845, i855, i865, i915, i945
 and i965 series chips.
 .
 This package also provides XvMC (XVideo Motion Compensation) drivers
 for i810/i815 and i9xx and newer chipsets.
 .
 More information about X.Org can be found at:
 <URL:http://www.X.org>
 .
 This package is built from the X.org xf86-video-intel driver module.
Original-Maintainer: Debian X Strike Force <debian-x@lists.debian.org>

 OR

Package: xserver-xorg-video-intel-lts-quantal
Priority: optional
Section: x11
Installed-Size: 1879
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: i386
Version: 2:2.21.15~precise~ppa1.1
Replaces: xserver-xorg-video-intel
Provides: xorg-driver-video, xorg-renamed-package, xorg-renamed-package-lts-quantal, xserver-xorg-video-intel
Depends: libc6 (>= 2.15), libdrm-intel1 (>= 2.4.38), libdrm2 (>= 2.4.30), libpciaccess0 (>= 0.8.0+git20071002), libpixman-1-0 (>= 0.21.6), libudev0 (>= 147), libx11-6, libx11-xcb1, libxcb-dri2-0, libxcb-util0 (>= 0.3.8), libxcb1, libxv1, libxvmc1, xorg-video-abi-13, xserver-xorg-core-lts-quantal (>= 2:1.12.99.901)
Conflicts: xserver-xorg-video-intel
Filename: pool/main/x/xserver-xorg-video-intel-lts-quantal/xserver-xorg-video-intel-lts-quantal_2.21.15~precise~ppa1.1_i386.deb
Size: 715406
MD5sum: b147920026872d41d82e205bfdba4fc7
SHA1: 34da13e65540e2221ee05a759113e7998492f9b9
SHA256: 03fde9de90208774dc8ea0675884d3f28a50c5d495d48759e165c6678724c019
Description: X.Org X server -- Intel i8xx, i9xx display driver
 This package provides the driver for the Intel i8xx and i9xx family
 of chipsets, including i810, i815, i830, i845, i855, i865, i915, i945
 and i965 series chips.
 .
 This package also provides XvMC (XVideo Motion Compensation) drivers
 for i810/i815 and i9xx and newer chipsets.
 .
 More information about X.Org can be found at:
 <URL:http://www.X.org>
 .
 This package is built from the X.org xf86-video-intel driver module.
Original-Maintainer: Debian X Strike Force <debian-x@lists.debian.org>


========================================

Rappel: https://launchpad.net/~glasen/+archive/intel-driver ………… I forgot to install or xserver-xorg-video-intel-lts-quantal or xserver-xorg-video-intel from Glasen PPA. I thought installing the PPA was enough. And I’ll uninstall xserver-xorg-video-intel-lts-saucy.

I’ll install xserver-xorg-video-intel-lts-quantal although I think xserver-xorg-video-intel is more compatible, but Precise is definitely -lts.

=====================================

 So the idea:

sudo apt-get remove –purge xserver-xorg-video-intel-lts-quantal

sudo apt-get install xserver-xorg-core xserver-xorg-video-intel

sudo dpkg-reconfigure xserver-xorg-core

sudo dpkg-reconfigure xserver-xorg-video-intel

becomes

sudo apt-get remove –purge xserver-xorg-video-intel-lts-saucy

sudo apt-get install xserver-xorg-video-intel-lts-quantal

sudo dpkg-reconfigure xserver-xorg-intel-lts-quantal

or

sudo apt-get remove –purge xserver-xorg-video-intel-lts-saucy

sudo apt-get install xserver-xorg-core xserver-xorg-video-intel

sudo dpkg-reconfigure xserver-xorg-core

sudo dpkg-reconfigure xserver-xorg-video-intel

wich means that before I had -lts-quantal ?!!!!!! And it did not work don’t remember why ?!

===============

=============================

Choice system (before any e-mail answer if any.)

Si j’installe server-xorg-video-intel ?
The card represents the critical factor for the issue at hand. Death: Death. Loss. Death and rebirth. End of an old situation and the beginning of a new one.

Si j’installe xserver-xorg-video-intel-lts-quantal ?
The card represents the critical factor for the issue at hand. Nine of Swords (Cruelty): Debilitating mental anguish or ill health. Being dragged down by the dishonor of others. Participation in a shameful or regrettable act. Inescapable guilt, mistrust, and doubt. May indicate a death or other catastrophic loss.

Donc j’ai la réponse.

(apt-show-versions -r xorg | grep core) && (apt-show-versions -r xorg | grep video-intel)
xorg-docs-core/precise uptodate 1:1.6-1ubuntu2
xserver-xorg-core-lts-saucy/precise uptodate 2:1.14.5-1ubuntu2~saucy1~precise2
xserver-xorg-video-intel-lts-saucy/precise uptodate 2:2.99.904-0ubuntu2.1~precise1

Bah oui, j’ai oublié qu’on changeait aussi le -xorg-core même si celui-ci est pourvu par Ubuntu et pas par le PPA.

Faut savoir ce qu’on a (ce qu’on a change) pour savoir par quoi on le remplace, regarder dans Synaptic s’il y a des doutes et dans la page du PPA pour l’avant-après.

sudo apt-get remove –purge xserver-xorg-video-intel-lts-saucy

sudo apt-get install xserver-xorg-core xserver-xorg-video-intel

sudo dpkg-reconfigure xserver-xorg-core

sudo dpkg-reconfigure xserver-xorg-video-intel

 

(Et à ce niveau faut savoir utiliser lightdm par cœur car ce sera ce qui remplacera tous nos futurs écrans noirs.)

Là lightdm par coeur (plus haut on avait obtenu xorg.conf et on l’a déjà personnalisé alors pas touche).

Ctrl-Alt-F1 (or F2, F3 etc.)
 Login: username
 Password: *****
(de mémoire parfois il demande aussi le nom de votre ordi dans username@nomdordi du terminal)
 sudo service lightdm stop
 sudo apt-get update; sudo apt-get upgrade
 sudo service lightdm start
 

Là une grosse question, je crois que j’ai fait quelque chose de à l’envers, la personnalisation de Xorg c’est après et pas avant  le changement de noyau + pilote Xorg. Donc je copie ma version pour la re-coller et je sauvegarde Xorg changé.

sudo gedit /etc/X11/xorg.conf (sauvegarde d’une copier dans /Documents)

Menu flottant > Comptes Utilisateurs > Mot de passe temporaire sans majuscules
 Ctrl-Alt-F1 (or F2, F3 etc.)
 Login: username
 Password: *****
 sudo service lightdm stop
 sudo X -configure
 sudo Xorg -configure
 sudo cp ~/xorg.conf.new /etc/X11/xorg.conf
 sudo service lightdm start

Si nécessaire mise à jour de la nouvelle version de xorg.conf avec l'ancien xorg.conf modifié.
Redémarrer  (plante pas stp !!!!!!!!!)

====

Avant: 1ère connexion : écran noir

2ème connexion: connexion avec erreur /tmp

Maintenant il se connecte directement, mais comme je n’ai pas re-paramétré Xorg, il met Unity sur l’écran mort, ce qui fait qu’il faut aller sur Affichage… à gauche pour le remettre et Firefox ne veut pas apparaître sur mon écran externe, plusieurs tentatives dans le terminal. Donc j’imprime tout et je configure Xorg.

 

Etant donné que après être allé sur lightdm (ça peut changer de nom à l’avenir c’est comme le DOS sans Ubuntu) et avoir re-configuré Xorg, je me rends compte que lui-même a re-paramétré Xorg tout seul à partir de mon précédent Xorg. La seule chose qu’il a enlevé c’est l’accélération SNA, sinon il n’a laissé que mes 2 écrans. Par contre faut que je re-démarre car il a fallu que je mette tout sur les 2 écrans, sinon tout ne va que dans l’écran mort.

Donc c’est pas le même xorg.conf, mais il retient nos préférences.

Moi je ne sais pas résoudre le problème: il m’ouvre tous mes programmes dans l’écran qui est mort et place tous mes documents du Bureau sur l’écran qui est mort, et il n’y a que quand je choisis d’afficher les 2 écrans qu’il les affiche.

Je pense que ça marche mais avec ce problème de décalage d’écrans. Ce qui fait que apriori pas d’écran noir mais plein d’erreurs d’affichage, d’où c’est mieux de ne pas installer le pilote en cours de route. Et de tout formatter et de tout re-installer avec le pilote au départ.

???

cat /var/log/Xorg.0.log | grep EE
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    25.867] (II) Loading extension MIT-SCREEN-SAVER
[    27.615] (EE) AIGLX error: dlopen of /usr/lib/i386-linux-gnu/dri/i965_dri.so failed (/usr/lib/i386-linux-gnu/dri/i965_dri.so: cannot open shared object file: No such file or directory)
[    27.615] (EE) AIGLX: reverting to software rendering
[    27.616] (EE) AIGLX error: dlopen of /usr/lib/i386-linux-gnu/dri/swrast_dri.so failed (/usr/lib/i386-linux-gnu/dri/swrast_dri.so: cannot open shared object file: No such file or directory)
[    27.616] (EE) GLX: could not load software renderer

dmesg | grep EDID | head -1
[   11.012036] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 21

dmesg | grep failed |head -4

OK (on va tout re-installer car il y a des petits soucis)

Mes premiers réglages sur Ubuntu Precise Pangolin 12.04LTS

Par défaut

Please see version 2:  intel black screen old laptop version 2 Precise

S’il vous plaît allez sur la version 2: intel black screen old laptop version 2 Precise

======================= Old / Périmé ===========================================

Mes premiers réglages sur Ubuntu Precise Pangolin 12.04LTS

Couleurs utilisées :

Instructions humaines : Magenta 4

Commandes dans le terminal : Bleu 2

Réponse du terminal et messages d’erreurs sur les bulles: Jaune 7

Tableau de bord : Rouge

Fichier texte : Vert 5

Titres : Orange 3 et Rouge 4

Introduction :

Dans les premières versions de Ubuntu il était conseillé de ne jamais installer 2 paquets au même temps ni de ne jamais modifier au même temps le système de 2 manières différentes. Je vous conseille de garder les vieilles habitudes vu que Precise (2013) est plus sophistiqué que les précédentes versions donc il vaut mieux éviter de créer soi-même des bugs. Mais contrairement aux versions précédentes, depuis Lucid Lynx LTS (le précédent LTS), il n’y a presque pas de bugs. Évitez juste d’installer votre LTS la première année où il est sorti parce que les logiciels tiers ne suivent pas le progrès à une telle vitesse.

Important

Mettre à jour les paquets (Cf. dock de Unity).

Choisir le bon « Affichage ».

Glisser déposer le « Terminal » sur le dock de Unity.

Sur le terminal taper : sudo apt-get update ; sudo apt-get upgrade

Choisir votre « Prise en charge des langues ».

Importez vos liens favoris, précédemment exportés, dans vos navigateurs web préférés.

Logithèque Ubuntu > Édition (menu flottant) > Sources de Logiciel > choisissez vos paramètres.

Personnellement je décoche les code sources, je coche le reste, et je choisis de n’être au courant que des LTS.

Sources de logiciels, reste une visionneuse de paramétrage de choix de mises à jour logicielles importante car elle affiche les dépôts de /etc/apt/sources.list (mais je ne sais pas si elle affiche aussi le contenu du fichier complémentaire sources.list.d), et on peut vérifier si il manque des clés d’authentification pour certains logiciels libres.

La plupart des PPAs (dépôts non officiels) sont là : https://launchpad.net/ubuntu/+ppas Mais on peut aussi en trouver sur des sites web. Vous saurez les installer quand vous en aurez besoin.

Tous les logiciels correspondant aux dépôts officiels et non officiels inscrits sur sources.list et sources.list.d/nom_fichier c’est à dire apparaissant dans Sources de Logiciels sont dans la Logithèque Ubuntu.

La mise à jour de la Logithèque se fait grâce à :

sudo apt-get update ; sudo apt-get upgrade

Mes préférences

Pour résoudre des soucis logiciels et matériels, je préfère renouer avec le passé et installer un deuxième moyen de visualiser les paquets de la logithèque. Ne pas l’ouvrir au même temps que la logithèque pour éviter les conflits d’installation.

sudo apt-get install synaptic