WordPress July 2015 re

Par défaut

1st Mum’s

2nd Mine

Publicités

WordPress June 2015 su

Par défaut

OK so 2 accounts, mine A and mum B, won’t tell name of internet hostings.

My A Side

== I have this plugin ==

Increase Max Upload Filesize

This plugin increase upload size limit up to 250Mb and more

Very Lightweight- Only 2KB

Installation very easy, just install & enjoy.

Any problem, Please Check FAQ Tab.

  • In the admin panel under plugins page, click Add New
  • go to Upload tab
  • browse « upload_max_file_size » and click install now
  • Click Active plugin
  • Increase File size size by click on Max File Size menu on the left hand side
  • Click on max_file_size and then enter the value in bytes Like: 262144000 bytes or 262144000 (You can Enter more value how much you want)
  • Example:(Like: 262144000 bytes = 250MB)
  • Enjoy!

Les deux sont dépassés, j’essaye le dernier.

Now google is not anymore giving the same conversion.
Now 10 megabytes = 10 000 000 bytes
So 15 megabytes = 15 000 000 bytes
So I have to change data to: 15000000
So now I can upload my bought themes and my bought plugins.

== Update themes and plugins and Increase memory size for Woo (although I won’t sell here, it’s just fix the error) ==

Premium themes – you must uncompress them then rename them like theme-july2015 to be able to update them manually. And to know all changes you’ve made. Selling website (or authors) can help if problems. Usually just re-zip does it.

Premium plugins – still don’t know how to read them, but read licence carefully. Some 1 domain only, others illimited domains. Have read the comments asking about that because Licences not understoodable, but when there is key, key blocks if you don’t first say, well there is a button to say stop key, de-activate, before you can re-install in same site or move to other site. So if wordpress deleted or if you move site (or if you test) you must de-activate then activate key, or ask authors inside selling site to de-activate it, that’s what I read. One time created plugins don’t have keys, keys is update function (alike repositories + keys).

Everything is pretty unsure here. I won’t install no more plugins that sends me thousands of e-mails about memory usage of an empty wordpress never used, because it sees memory usage of hosting and it thinks it’s my memory usage.

A- I am trying. Take 2: Create or re-use .user.ini inside /html (one per website) to set and change php limit size in managed WordPress. Since it is one per website and that I have a plugin with it inside. So change this plugin php files:

/home/My FTP username in my hosting/html/wp-content/plugins/upload-max-file-size/help

there is php.ini, php5.ini and .user.ini and .user.ini is a hidden file in Linux (so authorize hidden files, authoriser les fichiers cachés et juste rentrer dedans avec ouvrir en le tapant si on ne le voit pas). On les récupèrera avant avec FTP, puis on les re-mettra comme cela. So I won’t create a 4th php, since by seraching in FTP I already have 3 of them, not in /html, but in their folders and they are working so change them. I did not understood max limit of my host so let’s try max of max in host: 128 (but in some cases can be infinite).

php.ini

memory_limit = 128;
upload_max_filesize = 1024M
post_max_size = 1024M
php_value max_execution_time 500
php_value max_input_time 500

php5.ini

memory_limit = 128;
upload_max_filesize = 1024M
post_max_size = 1024M
php_value max_execution_time 500
php_value max_input_time 500

.user.ini

file_uploads = On
post_max_size = 1024M
upload_max_filesize = 1024M
memory_limit = 128;

and then FTP in the plugin folder: /home/My FTP username in my hosting/html/wp-content/plugins/upload-max-file-size/help

and let the plugin do the trick (oh they won’t update it hahaha) (tips: 1- serach in Filezilla FTP and 2- Just drag and Drop with FTP to replace files.)

I’ll see later if it works, let it sleep =)

Mum B side

(noo wordpress is not saving :/)

Anyway the low price website forever (no names) is worse then free unlimited site where I can get better material service.

I created subdomain to install wordpress and keep cpanel space for other things.
I did not create e-mail because https is said to be protected by themselves and we must ignore don’t enter.

Softaculous is free demo version so can’t install nothing lol, even free forever that delete sites have paid to get paid version for us lol. But anyway I created a database in PhpMyAdmin that didn’t look very evolved, created user and added permissions to user.

Then I’ll install by hand WordPress I have downloaded, I think I’ll have to SFTP it unzipped.

Now I have to create SFTP connection… complicated but will find out =) I already had created SSH key. But is the password, the password for SFTP? Did I understood it all ? Must I create a new FTP account ? I’ll test until it works.

Saw this, will read: https://www.doitwithwp.com/how-to-set-up-sftp-with-cpanel/

Couldn’t do SFTP, did FTP. Had to create all database like in PC, so did it and had put same information in WordPress for it to connect to DB. So what I can do at home, I can do online. Besides site puts you offline if you put wrong FTP.

Let’s go for installs !!!

What were my plugins ???

====

Still not there, I’ll keep mum’s hosting : it’s one small space, wow they answer quick and nice and precise =) ❤ ❤ <3, can install WordPress with FTP but they’ll soon have one click =) Sure they will keep because limited space.

And my hosting is also a buy once for all your life, but with adds, sure they will keep, not because of space: all unlimited hahaha, but because of adds. So that’s 2 choices of buy once: either limited space, either with adds. So A still A and B is new B.

I must be crazy to pay for a website with adds but they promised quality inside and all unlimited and all for life no more annual payments, so good, hehehehe, a lot of good hopes.

And no worries about site being deleted because I paid for infinity =)

=====

Double boot Windows 8.1 OEM sans CD – Ubuntu Linux Trusty Tahr 10.04 LTS+

Par défaut

Double boot Windows 8.1 OEM sans CD – Ubuntu Linux Trusty Tahr 10.04 LTS+, comment ai-je fait pour l’installer sur mon Acer Aspire E1-530G vers 2014-2015 ?

I – Discussion

II.A- Action + Préparation (les consignes qui manquent à la vieille installation)

II.B- Action + Réparation (parce que je vous expliquerais à partir d’une vieille installation)

I – Discussion

Autrefois le double boot Windows XP Pro – Ubuntu Linux était très facile à réaliser, mais actuellement nos propres ordinateurs portables ont un système de sécurité trop étanche (rien à voir avec internet, juste avec le droit d’installer un autre système d’exploitation ou de récupérer nos propres données sur notre propre disque dur afin de les sauvegarder) qui empêche le double boot, cependant ce qui est complexifié n’est pas impossible pour les amateurs de Linux.

Windows, après avoir solidifié les bases de Windows XP, a pris le parti de l’évolution pour imiter Linux et sortir une nouvelle version tous les ans. Cependant au lieu de faire comme Linux qui a même inventé Wine et Alien pour faire tourner quelques .EXE et quelques .RPM parmi ses .DEB, et qui contrairement à Windows détecte les partitions NTFS en plus de ses partitions EXT4, et qui contrairement à Windows permet d’afficher et d’utiliser depuis EXT4 les partitions NTFS ; Windows s’attaque à ses concurrents : la VirtualBox ne marche plus puisque Windows hésite à rendre la sienne payante et que pour accéder à la sienne gratuitement, il faut quand même se payer Windows 8,1 pro. Du coup comme c’était l’anti-spyware que Windows rendait responsable de ce problème d’installation de la VirtualBox, et que la VirtualBox ne s’installe pas non plus dans un Windows nu sans Avast et sans anti-spyware, alors j’ai investit dans l’anti-spyware pro, juste pour 1 année.

Le principe de l’évolution est gratuit pour Linux, mais ne peut pas l’être pour Windows. Tout d’abord faire subir à Linux un saut évolutif risque de nous faire perdre Linux et ses données, donc il faut sauvegarder tout son disque dur ou tout mettre sur une partition cloîtrée au cas où l’évolution de Windows 8.1 vers Windows 10 se transforme en gâteau qui dégonfle à la sortie du four. Or pour Windows le temps de ré-installer tous ses programmes de zéro et de remettre tous ses fichiers en place est 10x plus long que sur Linux. Ensuite les programmes payants ou gratuits de la version 8.1 ne seront pas forcément futuro-compatibles avec la version 10, c’est aussi le cas des programmes Linux. Sauf que Linux possède toujours l’avantage des dépôts internes (La logithèque Ubuntu) et externes (Launchpad, Canonical, dépôts publiques, privés et d’entreprises) que Windows n’a pas compris l’intérêt, donc qu’il n’a pas encore copié, et qui permet à tous les programmes de l’ancien Linux dont le développeur a conçu une version compatible avec le nouveau Linux, de se mettre à jour sans qu’on ait à le re-installer de zéro. Enfin il y a la question des pilotes, le problème c’est qu’un pilote montre toujours son nom générique, mais que souvent les constructeurs d’ordinateur modifient et l’engin qu’ils contrôlent et le programme informatique du pilote selon ses normes et ses préférences d’usage, comme Windows était stable, certains pilotes de votre ordinateur ont été personnalisés à votre insu, et donc on a acheté Windows 8.1 avec des pilotes fonctionnels, et si on efface son pilote d’origine ou si on change Windows de version, on peut ne plus jamais trouver un pilote (angl. driver) qui fonctionne pour un engin mécanique de son ordinateur. Moi j’ai ce problème avec NVIDIA qui ne fonctionne pas de manière autonome dans Windows, donc tous les pilotes qui lui diraient sous Linux de prendre le contrôle de ma carte graphique, vu qu’il n’est pas assez puissant, iraient crasher mon ordinateur, car mon NVIDIA complète mon pilote VGA de Intel, mon ordinateur ne marche pas à l’un ou à l’autre. Et sous Windows il faut acheter un programme pour mettre à jour tous ses pilotes à sa version de Windows. Alors que sous Linux, bien que certains sites web vendent ces mises à jour, 98 % de nos pilotes sont gratuits puisque mis à jours de manière générique, en ignorant tous les petits détails apportés à l’origine par chaque constructeur d’ordinateur, les pilotes de Linux sont des pilotes pour toutes les marques d’ordinateur qui existent au même temps du coup c’est normal si une ou deux fonctions de notre ordinateur comme l’éclairage ne sont pas fonctionnelles.

Un truc que j’ai fait il y a longtemps : pour ce qui est de la virtualisation de Windows 7 et Windows XP pack 3, Windows 8.1 version Familiale intègre gratuitement le mode compatibilité vers les anciennes versions de Windows, sans avoir besoin d’acheter Windows Pro, et sans avoir besoin d’installer une machine virtuelle et sans avoir besoin d’installer le mode compatibilité. Cependant j’ai eu du mal à trouver la manière d’y procéder : il faut aller jusqu’à la fin du processus et installer le .EXE en tant qu’administrateur. Il n’y a pas de fenêtre virtuelle, c’est juste le mode d’installation et de lancement qui se trouvent modifiés depuis la souche même de Windows, de manière invisible à condition de l’avoir choisi comme option. Sont intégrés aussi le programme de partitionnement (le Gparted de Windows, j’ai fait cela il y a longtemps alors à vous de le retrouver) ainsi que l’invite de commandes (un ex-DOS qui contrôle le hardware pour imiter le terminal de Linux), donc il y a quand même un air de Linux niveau programmes prêts à l’emploi. Cette invite de commandes Windows fait l’objet de polémiques très graves dans le monde de Linux car avant il n’y avait que les linuxiens qui accédions au hardware par le terminal (je ne suis pas informaticienne alors les termes…), par hardware je veux dire : partitionner le disque, obtenir des informations sur les pilotes niveau matériel et niveau nom du logiciel, et surtout le contrôle du Grub et du double boot, bref l’essentiel de la vie sur Terre. Puisqu’en virant DOS, Windows s’était assuré du fait que ses utilisateurs n’avaient pas le moindre contrôle sur leur système d’exploitation. Donc retour du DOS, retour du contrôle donc polémique. Surtout que en reprenant le contrôle du double boot, Windows a trouvé un moyen d’enfermer les linuxiens dehors en leur volant leur technologie. C’est pas très sympathique car notre technologie est Open Source, elle vise le partage. Cependant ceux qui défendent qu’on peut se passer du terminal de Windows n’ont pas l’esprit assez ouvert pour accepter que les simples utilisateurs comme moi, ne cherchent que une solution simple et efficace pour leur double boot, et pas un contrat philosophique avec un parti pro ou anti Windows, bien que au fond on utilise Windows en étant des anti-Windows. On ne veut que quelque chose qui fonctionne et tant pis si on passe par le terminal de Windows, mais ça ne signifie pas qu’on pense qu’il faille passer par le terminal de Windows, nous on accepte que plusieurs chemins mènent à Rome, on veut juste aller à Rome et on s’en fiche du chemin.

Si Windows était intelligent il s’ouvrirait à lire notre partition EXT4 depuis sa partition NTFS et il accepterait le système de dépôts et de clés de mises à jour signées gratuitement. Additionner plus de sécurité c’est débile quand la plupart des particuliers ne sont pas la NASA et ne cachent pas d’immenses secrets. C’est intéressant pour les entreprises qui ont des prototypes mais pas pour les étudiants débiles qui veulent cacher leur mémoire de la communauté scientifique. Additionner du partage cela aurait été bien plus intelligent. Et donc Windows qui est contre le partage ne sait pas comment faire quand il va commencer à sortir un Windows par an ? Il hésite à prendre le chemin du Open Source, qui est le seul qui propose une solution pour l’évolution fulgurante des systèmes d’exploitation. Oui il faut acheter des logiciels Windows qui offrent des mises à jour à vie à ne payer qu’une seule fois ou utiliser des logiciels Windows gratuits que trop de gens utilisent pour que les mises à jour continuent d’être distribuées gratuitement. Mais bon avant de penser à faire un upgrade, il faut s’assurer qu’on ne va pas détruire notre si bon double boot, difficile à obtenir.

Finalement j’ai fait l’Upgrade et ça ne l’a pas détruit mais j’ai du donner l’ordre depuis Windows qu’il réapparaisse avec la commande sur l’invite de commande Windows (admin):

bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

II.A- Action + Préparation

! Avoir un DVD-R jetable et pas un CD-R est impératif car il faut tout faire à partir du DVD-R de Ubuntu, en gravant son image ISO (pas un disque de données, une image ISO = un système d’exploitation ou un programme qui fonctionne de lui-même). ! Les précédentes versions de Ubuntu sont périmées, on peut jeter leurs DVD-R et CD-R à la poubelle et ne garder que la dernière qui au moment où je parle s’appelle Wily !

Où trouver le Gparted de Windows ?

Chercher dans Cortana ou dans le Panneau de Configuration de Windows:

Créer et formater des partitions de disque dur. Il faut créer une partition NTFS unique pour Ubuntu, c’est Ubuntu qui la divisera en deux partitions: la partition EXT4 où on met la racine / + la petite partition pour le RAM dit Swap. Se concentrer sur la taille des partitions pour reconnaître celle pour Ubuntu. Il faut que sa taille soit unique. La mienne fera 227 Go en NTFS. Et il y aura 8 partitions qui deviendront 9 partitions.

/dev/sda6     968200192 1431091199 462891008 220,7G Linux filesystem
/dev/sda7    1431091200 1444071423  12980224   6,2G Partition d'échange Linux

Comment rajouter un mot de passe au démarrage de Windows pour que le câble Ethernet soit reconnu même après démarrage ?

Proposer 3 mots de passe au Bios ne dégrise rien, cela rajoute pour l’un d’entre eux un mot de passe pour démarrer le disque dur (Sata ?) avant de démarrer l’écran Acer, avant de démarrer le Bios (F2 ou F12) et avant de démarrer Windows. Dans le mien ce qui est gris est inchangeable et ce qui est bleu est changeable. (Le disque dur peut aussi être démarré sans mot de passe et dans ce cas Ethernet n’est pas reconnu.)

Je vous propose ce qu’il y a sur mon Bios:
F2
Information
CPU Type: Intel(R) Pentium(R) CPU 2117U @ 1.80GHz
CPU Speed: 1.80GHz
System BIOS Version: V2.06
etc.

Main

System time
System Date
Total Memory
Video Memory

Network Boot  [Disabled]
F12 Boot Menu  [Enabled]
D2D Recovery  [Enabled]
Wake on LAN  [Disabled]
SATA Mode  [AHCI Mode]

Security
Supervisor Password is: Set (non changeable)
User Password is: Set (non changeable)
HDD ¨Password is: Set (non changeable)

Set Supervisor Password: [Enter]
Set User Password: [Enter]
Set HDD ¨Password: [Enter]

Password on Boot: [Disabled]

Secure Boot Mode [Standard] (non changeable)
Erase all Secure Boot Setting [Enter] (non changeable)
Select an UEFI file as trusted for executing [Enter] (non changeable)
Restore Secure Boot to Factory Default [Enter] (non changeable)

Boot
Boot Mode [UEFI]
Secure Boot [Disabled]

Boot priority order:
USB FDD
USB HDD
ATAP I CDROM
USB CDROM
Windows Boot Manager
HDD
Network Boot-IPV4
Network Boot-IPV6

Exit
Exit Saving Changes
Exit Discarding Changes
Load Setup Defaults

Comment rendre les dossiers de Windows 8.1 montables dans Ubuntu à partir de Windows 8.1?

L’erreur du mount vient du fait que Windows utilise fast startup pour se connecter. Donc même lorsqu’on arrête totalement l’ordinateur, il est dans une espèce de veille qui n’en est pas une. Et on ne peut pas monter ses partitions car si on les montait, on effacerait sans vouloir une partie des données de la dernière veille. Enfin, je ne sais pas expliquer car je ne suis pas informaticienne. Mais fast startup équivaut à une partition en cours d’usage telle une clé USB dont les fichiers viennent d’être copiés dessus et qu’on ne peut pas arracher à la prise. La désactivation du fast startup n’a pas eu d’effet temporel pour ma part ni sur mon ordinateur neuf (non surchargé), et n’a pas bloqué le live DVD comme on dit que ça le fait.

Donc j'ai fait (pour les Windows 8.1 en français):
clic droit ou Win+X > Options d'alimentation > 
Choisir l'action des boutons d'alimentation > 
Modifier les paramètres actuellement non disponibles >
DESACTIVER -> Activer le démarrage rapide

Fast startup c’est le démarrage rapide. Et là j’ai éteint l’ordinateur. Je l’ai démarré. J’ai mis mon mot de passe du disque dur. Mon DVD live a booté automatiquement (avant le Bios qui n’a jamais rien reconnu comme périphérique bootable à part Win). Et toutes les partitions lisibles de Windows ont été montées. C:\ marche, D:\ marche, tout marche, même si surprise Windows a plein de partitions bizarres.

Moi j’en ai créé une pour les documents partagés même si C:\ les partage aussi. Plus de l’espace (je ne sais plus le nom), des octets libres sans NTFS et sans partition pour Ubuntu (Win a tout comme Linux son propre programme de partitionnement intégré mais qui fait que NTFS). Mais il y a en plus au total 7 partitions appartenant à Windows 8.1 dans mon ordinateur dont 1 en format inconnu pour Ubuntu, lesquelles même si on n’en accède que à quelques unes, il ne faut pas toucher:
– Recovery NTFS 400MiB
– ESP FAT32 300Mib
– unknown 128Mib flag msftres (sûrement le Grub de Windows ?)
– Acer NTFS 460,86 Gib (le C:\ désormais totalement accessible sans démarrage rapide)
– unallocated 226,91Mib (pour Ubuntu)
– FTD NTFS 226,91Mib (pour les dossiers partagés)
– unallocated 1Mib
– Push Button Reset NTFS 16,01Gib

Pour ce qui est des 460Gib du C:\, l’outil de défragmentation m’a dit que ce n’étaient pas des fichiers déplaçables. Je ne sais pas encore où est mon Home de Windows mais puisque je peux y accéder, il y a de quoi stocker.

Comment après installation de Ubuntu avoir un Grub de Ubuntu qui nous donne le temps (en secondes) de le choisir et d’y loguer ?

sudo gedit /etc/default/grub
je mets ---> GRUB_TIMEOUT=60
sudo update-grub

Comment après installation de Ubuntu avoir Windows dans le Grub de Ubuntu ?

Il faut avoir au préalable installé Boot-Info. Avec cette méthode on peut aussi faire en sorte que Ubuntu prenne le contrôle du Grub de Windows mais ce n’est pas ce que j’ai fais. Moi j’ai créé le Grub de Ubuntu avec Windows dedans et ensuite j’ai lancé la commande depuis Windows pour que le Grub de Ubuntu soit dépendant de celui de Windows. Du coup il n’y a que lui aui apparaît mais c’est Windows qui contrôle le Grub de Ubuntu. Mais on ne voit pas le Grub de Windows (je crois que c’est F5 le Grub de Windows d’après mes souvenirs).

-
redémarrer + F12
mot de passe bios
secure boot enabled + sauver (non, en réalité c'est disabled dans mon cas)
-
Etape 1:
redémarrer + F12
Boot option menu de Win + Grub de Ubuntu
-
Etape 2:
fran@earendil-light:~$ sudo efibootmgr -v
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0000,0002,0001
Boot0000* Windows Boot Manager	HD(2,c8800,96000,68c5d689-09dd-4ad6-bd9b-95b0b80a9cdf)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...5................
Boot0001* HDD: 	HD(2,c8800,96000,68c5d689-09dd-4ad6-bd9b-95b0b80a9cdf)File(\EFI\ubuntu\grubx64.efi)RC
Boot0002* ubuntu	HD(2,c8800,96000,68c5d689-09dd-4ad6-bd9b-95b0b80a9cdf)File(\EFI\ubuntu\shimx64.efi)
Boot0003* HL-DT-ST DVDRAM GUA0N           	BIOS(3,500,00)................-.v.......v.A.v....#...................................

Etape 3:
fran@earendil-light:~$ sudo grub-install
Installing for x86_64-efi platform.
Installation terminée, sans erreur.

Etape 4:
fran@earendil-light:~$ sudo efibootmgr -v
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,0000,0001
Boot0000* Windows Boot Manager	HD(2,c8800,96000,68c5d689-09dd-4ad6-bd9b-95b0b80a9cdf)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...5................
Boot0001* HDD: 	HD(2,c8800,96000,68c5d689-09dd-4ad6-bd9b-95b0b80a9cdf)File(\EFI\ubuntu\grubx64.efi)RC
Boot0002* ubuntu	HD(2,c8800,96000,68c5d689-09dd-4ad6-bd9b-95b0b80a9cdf)File(\EFI\ubuntu\shimx64.efi)
Boot0003* HL-DT-ST DVDRAM GUA0N           	BIOS(3,500,00)................-.v.......v.A.v....#...................................
fran@earendil-light:~$ 

Comment après installation de Ubuntu avoir Ubuntu dépendant du Grub de Windows ?

bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

II.B- Action + Réparation

Comme cela s’est passé il y a longtemps, Ubuntu avait déjà été installé, mais là il a plein de bugs, il freeze, peut-être que cela provient du Disque Dur. Donc là on aura le check up du vieux Ubuntu avec l’installation du nouveau:

sudo fdisk -l
Périphérique      Start        Fin  Secteurs   Size Type
/dev/sda1          2048     821247    819200   400M Windows recovery environment
/dev/sda2        821248    1435647    614400   300M EFI System
/dev/sda3       1435648    1697791    262144   128M Microsoft reserved
/dev/sda4       1697792  967176223 965478432 460,4G Microsoft basic data
/dev/sda5     967178240  968200191   1021952   499M Windows recovery environment
/dev/sda6     968200192 1431091199 462891008 220,7G Linux filesystem
/dev/sda7    1431091200 1444071423  12980224   6,2G Partition d'échange Linux
/dev/sda8    1444071424 1919942655 475871232 226,9G Microsoft basic data
/dev/sda9    1919944704 1953523711  33579008    16G Microsoft basic data

On m’a demandé d’installer:

setxkb,qp fr                    < à l'écran cela s'affichera setxkbmap fr 
sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu $(lsb_release -sc) universe"
sudo apt-get update
sudo apt-get install --no-install-recommends smartmontools 

Et de poster le résultat de:

sudo smartctl  -s  on   /dev/sda6
sudo smartctl  -a        /dev/sda6

Je tiens également à faire la révision des mauvais blocks et le check up:

sudo badblocks -sv /dev/sda6
sudo fsck /dev/sda6

II.B- Action + Installation du DVD

Aucun souci, là pour réinstaller Ubuntu et tout supprimer:

/dev/sda6 ext4 avec le point de montage sur la racine = root =  / donc on écrit que: /

/dev/da7 formaté en ext4 puis en swap de nouveau

Grub de Ubuntu placé sur /dev/sda6 et pas sur /dev/sda pour pas que Win le touche avec ses mises à niveau.

Mise à jour de la Prise en charge des langues et rajout du Portugais.

Désélection des Mises à jour non gérées, je ne garde que les 2 premières qui sont gérées, dans Sources de Logiciels.

Désactiver le Wifi pour passer en filaire: Ethernet c’est mieux sans les ondes Wifi.

Retour au début avec boot-info puis le Grub de Windows sur l’invite de commandes. Mes étapes ne sont pas dans l’ordre.

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair boot-info
(boot-info 
noter le numéro de rapport en ligne)

sudo efibootmgr -v

sudo grub-install

sudo efibootmgr -v

Sur l'Invite Windows taper:
bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

OK

—-
Autres éléments importants: l’icône Affichage car j’utilise un écran externe, seulement projeter le pc sur 1 écran, et finalement je peux choisir la taille des lettres sur l’écran externe, donc je l’ai mise plus grande =)


Ma personnalisation 1:

sudo add-apt-repository ppa:ravefinity-project/ppa
sudo apt-get update
sudo apt-get install vivacious-colors
sudo apt-get install vivacious-folder-colors-addon

Ma personnalisation 2:
sudo add-apt-repository ppa:ravefinity-project/ppa
sudo apt-get update
sudo apt-get install ambiance-blackout-flat-colors

Ma personnalisation 3:
Logithèque: Unity Tweak Tool

Ma personnalisation 4: Splash Screen
installer: solar.plymouth et plymouth.ubuntustudio
sudo update-alternatives –config default.plymouth
taper le bon numéro
sudo update-initramfs -u

Suite:
Re-listage des programmes sous Wily

Monter des videos avec OpenShot sans planter ?

Par défaut

Extraits des posts…

« … » = citation de moi-même sur le Forum Ubuntu, quand c’est quelqu’un d’autre, je cite le nom.

 » Bonjour, mon ordinateur Aspire E1-530, Intel Pentium 2117U Processor (1.8 GHz, 2MB L3 cache) a 6 GB DDR3 Memory de mémoire vive.  »

J’ai  OpenShot (version 1.4.3) car Cinelerra n’est plus d’actualité, c’est comme Open Office qui a été remplacé par Libre Office, Cinelerra sera remplacé par Lumiera toujours en version de développement.

 » Que faire pour lui dire de ne pas planter ?  »

1) J’installe OpenGL en suivant la doc puis je redémarre avant de vérifier:

sudo apt-get install freeglut3
glxinfo | grep direct
/usr/lib/nux/unity_support_test -p

2)  » Tout ce qui est Bumblebee ou Nvidia-Prime, etc. ne m’intéresse pas car ce n’est pas ce que j’ai puisque mon NVIDIA a été personnalisé par Aspire, donc non utilisable côté Ubuntu, je n’ai pas du tout besoin de lui. Je regarde d’autres solutions.  »

3) nam1962 m’a conseillé :  » Essaie les dépots oibaf et règle aussi ta swappiness à 5 « . Ce que j’ai fait.

4) Pour votre ordinateur, regardez les conseils du dépôt Oibaf dans Launchpad, pour le mien c’est cela:

 »

sudo apt-get install mesa-vdpau-drivers
sudo apt-get install mpv

fran@earendil-light:~$ lspci -vnn | grep nouveau
	Kernel driver in use: nouveau

* Supported VDPAU drivers: r300, r600, radeonsi, nouveau *
*test the VDPAU driver with mpv*
fran@earendil-light:~/Vidéos/Siege beginning April 2015$ mpv --hwdec=vdpau Siege4thApril2015.ogv 
Playing: Siege4thApril2015.ogv
[libav/demuxer] ogg: max_analyze_duration 5000000 reached
File tags:
 RECORDMYDESKTOP: 0.3.8.1
[stream] Video (+) --vid=1 (theora)
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[vo/vdpau] Error when calling vdp_device_create_x11: 1
[vo/opengl] Missing OpenGL features: [NO_SW]
[vo/opengl] Rejecting suspected software OpenGL renderer.
[vo/opengl] OpenGL context creation failed!
[vo/xv] No Xvideo support found.
[vo/sdl] Using opengl
Using software decoding.
Audio: no audio
V: 00:00:00 / 00:09:08 (0%)
VO: [sdl] 1312x752 => 1312x752 yuv420p

fran@earendil-light:~$ lspci -vnn | grep i915
	Kernel driver in use: i915

*To run your OpenGL program with classic i915 driver*
fran@earendil-light:~$ LIBGL_DRIVERS_PATH=/usr/lib/dri-alternates glxgears -info
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
GL_RENDERER   = Gallium 0.4 on llvmpipe (LLVM 3.5, 128 bits)
GL_VERSION    = 1.4 (3.0 Mesa 10.4.0-devel)
GL_VENDOR     = VMware, Inc.
GL_EXTENSIONS = GL_ARB_depth_texture GL_ARB_draw_buffers

lsb_release -c
Codename:	utopic

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt-get update; sudo apt-get upgrade

 »

5) Ensuite il y a le Script de debug par OpenShot

 »

1) download
2) launch: sudo python debug.py
3) sudo updatedb
4) fran@earendil-light:~$ locate openshot.debug
/home/fran/Documents/Permanent/openshot.debug
5) sudo gedit /home/fran/Documents/Permanent/openshot.debug
6) J'ai: WARNING: /usr/lib/pymodules/python2.6 missing from Python Path
7) Or mon Python est plus récent donc il faut installer l'ancien aussi.
(apt-cache show python | grep Version)&&(apt-cache show python | grep Replaces)
    Version: 2.7.8-1
    Replaces: python-dev (<< 2.6.5-2)
sudo add-apt-repository ppa:fkrull/deadsnakes
sudo apt-get update
sudo apt-get install python2.6
8) Et là on va voir. Tout redémarrer de nouveau. 

 »

6) Après hésitation, je vais suivre ton conseil pour la Swapiness à 5 (je n’ai pas mis à 5 mais à 6) – Ubuntu a bien ouvert à 10:

 »

cat /proc/sys/vm/swappiness

C’était 60 maintenant c’est 10 et là je vais mettre 6 (je n’ai pas mis à 5 mais à 6).

sudo gedit /etc/sysctl.conf

J’ai écrit:
#################################
# Swappiness
vm.swappiness = 6

Redémarrer.

 »

7)  Conclusion:  » Il y a 85% de moins de soucis, et enfin je peux la plupart des fois voir le résultat sur OpenShot avant d’enregistrer sans aucun bug, alors c’est beaucoup mieux.  » Donc ça marche pour le fait maison, pour le pro faudrait trouver 2-3 boosts en plus mais au moins on peut travailler dessus et c’est ce qui compte… je fais la vidéo d’un jeu pour et avec mes amis de internet.

First Mojo theme config – for mum jan 2015

Par défaut

I did that in free course with CMA:

https://support.google.com/analytics/answer/1042508

Configurer une propriété

Une propriété représente l’endroit où vous envoyez les données et configurez les vues des rapports.

Seuls les utilisateurs qui disposent d’une autorisation de modification peuvent ajouter une propriété à un compte Google Analytics.

En savoir plus sur les propriétés

Pour configurer une propriété, procédez comme suit :

  1. Connectez-vous à votre compte Google Analytics[/0}. Cliquez sur Admin dans la barre de menu situé en haut de la page.
  2. Dans la liste déroulante de la colonne Compte , sélectionnez le compte auquel vous souhaitez ajouter la propriété.
    Si vous disposez d’un grand nombre de comptes, utilisez le champ de recherche pour vous aider à trouver le compte concerné.
  3. Dans la liste déroulante de la colonne Propriété , cliquez sur Créer une propriété .
  4. Sélectionnez Site Web ou Application pour mobile .
  5. Indiquez le nom du site Web ou de l’ application .
    Si vous prévoyez d’effectuer le suivi de plusieurs applications dans votre compte, choisissez un nom très précis et descriptif, incluant l’édition ou le numéro de version. Vous pourrez ainsi organiser vos applications plus facilement.
  6. (Web uniquement) Saisissez l’ URL du site Web .
    Vous ne pouvez pas créer de propriété si le format de l’URL n’est pas correct.

  7. Sélectionnez une catégorie sectorielle .
  8. Sélectionnez le fuseau horaire des rapports .
    Il servira de repère temporel pour vos rapports, quelle que soit l’origine de vos données.

  9. Cliquez sur Obtenir un ID de suivi .
    Votre propriété est créée lorsque vous cliquez sur ce bouton, mais vous devez configurer le code de suivi pour collecter les données .

Vous me croirez pas, mais l’interface Google Analytics de mon thème a mystérieusement disparu ? Problème de compatibilité ? Ou peut-être était-ce l’hébergeur puisqu’il propose cela en payant (même si j’ai acheté 1) ? J’ai installé un plugin gratuit qui fait la même chose.

Finalement je l’ai retrouvé, c’est sûrement le thème qui a changé sa présentation côté administrateur, car c’est vraiment dans un endroit où on ne s’y attend pas. Donc le plugin, je supprime.

=================

WPML (je l’ai acheté parce que je suis une linguiste, et comme je n’ai pas de travail dans le domaine, au moins que j’ai pour moi-même le meilleur du marché surtout que les profs c’est tout pour eux et rien pour les élèves, et là je possède la traduction automatique à vie hahaha)

installer/activer (pcq je désactive tout ce que je ne connais pas) string translation / traduction de chaînes permet de télécharger tous les .mo en-ligne absents du thème s’il y en a (je ne sais pas si changer la langue de WordPress lui forcera à en trouver d’autres, mais on peut essayer).
-> ça: WPML téléchargera automatiquement les traductions pour WordPress

Et ne pas mettre le surligneur, qui permet de montrer où a été traduit quoi car ça occupe de l’espace:  » Rechercher où la chaîne apparaît sur le site « . A ne mettre on que lorsqu’on veut savoir précisément ce qu’on traduit.

Le thème doit être traduit par soi-même quand il ne vient pas traduit. Donc on sélectionne les langues qu’on connaît et puis on traduit.

====================================
Désactiver l’Éditeur d’Extension et de Thème

Occasionnellement, vous pouvez désactiver l’éditeur d’extension ou de thème pour empêcher les utilisateurs trop zélés d’être en mesure de modifier les fichiers sensibles et provoquer un crash du site. La désactivation de celles-ci fournit également une couche de sécurité supplémentaire si un pirate parvenait à accéder à un compte utilisateur privilégié.

/*I added*/
define(‘DISALLOW_FILE_EDIT’,true);

Rem: N’étant pas informaticien, on n’a pas à toucher ce truc, c’est pas les pirates que je crains, c’est la bêtise. Edité avec Filezilla, il ne faut pas sortir de la zone de login FTP. Parce qu’après c’est délirant.

-> Il n’a pas altéré le code source car je ne dispose pas de ce droit. GRRRRRRR

De toutes les manières, maintenant que je veux allow tout, je ne peux pas!

====================================================

installés pour l’instant:
WPML Media
Désactiver | Modifier | Registered
Add multilingual support for Media files
Version 2.1.8 | Par OnTheGoSystems | Aller sur le site de l’extension

WPML Multilingual CMS
Désactiver | Modifier | Configurer | Registered
WPML Multilingual CMS. Documentation.
Version 3.1.8.4 | Par OnTheGoSystems | Afficher les détails

WPML String Translation
Désactiver | Modifier | Configurer | Registered
Adds theme and plugins localization capabilities to WPML. Documentation.
Version 2.0.14 | Par OnTheGoSystems | Aller sur le site de l’extension

Sélectionner WPML Translation Analytics WPML Translation Analytics
Désactiver | Modifier | Registered
Shows the status of translation projects and displays warnings when
Version 1.0.6 | Par OnTheGoSystems | Aller sur le site de l’extension

WPML Sticky Links
Désactiver | Modifier | Configurer | Registered
Prevents internal links from ever breaking. Documentation.
Version 1.3.7 | Par OnTheGoSystems | Aller sur le site de l’extension

Il faut se loguer pour voir: http://wpml.org/documentation/wpml-core-and-add-on-plugins/

===================================================

Plugin très bien car pas moyen d’afficher l’HTML de WordPress (l’onglet TEXT ne marche pas). Et pas moyen non plus d’installer un éditeur de texte: tous font des bugs.

https://wordpress.org/plugins/visual-editor-custom-buttons/

Looking for a fast and easy way to add custom buttons to the WordPress Visual Editor? Visual Editor Custom Buttons is the answer. With this plugin, you can easily add your own custom buttons in the Visual Editor, as well as the HTML Editor. You can then add HTML code to the button, either as a wrap (before, after) or as a single block. On top of that you can, from within the plugin, set the CSS so you can view the effect of the button directly in the Visual Editor.

Il existe un payant d’un autre auteur mais plus ancien, celui-ci est gratos 😉

=====================================================

Les polices de caractère au niveau des titres:

Big problem, my hosting do not give permissions to upload. And I can’t change permissions from FileZilla. Gonna try SSH to change perm ? I don’t want to pay 10euros to do this!

Synaptic -> taskel (sélectionner les paquets par tâche) -> install (the best) openssh-server

ssh -V
OpenSSH_6.6.1p1 Ubuntu-8, OpenSSL 1.0.1f 6 Jan 2014

sudo service ssh start

D’après la Doc et d’après l’Hébergeur, il faut faire avec ses coordonées FTP:

ssh <nom_utilisateur>@<ipaddress> -p <num_port>

On peut aussi se connecter avec Git Hub mais là on essaye SSH. ipadresse là on met les numéros du nom de domaine DNS.

Ne marche pas et il n’y a pas de manière de Enable your admin (root and sudo) access permission, donc faudra contacter le site.

Je peux aussi essayer d’acheter 10$ de http://dnesscarkey.com/font-convertor/api/ et c’est ce que je vais essayer: Use Any Font.

J’ai demandé à Any Font comment fonctionne leur licence pour 2 sites web car aucune explication…

=================

Alors j’ai pas attendu, j’ai acheté la formule la – chère car je ne peux pas +

=================

Use Any Font plugin: http://dnesscarkey.com/font-convertor/api/
For me code to assign is:
#logo a span

How to find it ? With console > Inspecteur.

My hosting is not a+w so I can only correct with FTP. Theme is @ /html/wp-content/themes/nom-du-theme

Then go to console > Editeur de Styles > styles.css (but as I said, I’m u+w not a+w)

Original:
 »
Title Page
============================================================================= */
header#titlehead h1#pagetitle, #tophead h1#pagetitle{margin:0 0 16px;padding:0;position:relative;letter-spacing:1px;text-transform:uppercase;font-size:150%}
header#titlehead h1#pagetitle span, #tophead h1#pagetitle span{padding:0 0 5px;display:inline-block;position:relative;bottom:-1px}
 »

So in section:
Title Page
============================================================================= */
delete: text-transform:uppercase;
put: font-size:200%

Then FTP to /html/wp-content/themes/nom-du-theme/styles.css

What is console ? There are for all: Firefox, Chrome, Internet Explorer, Safari, etc…
Here in Firefox: https://developer.mozilla.org/fr/docs/Outils/Style_Editor

===========================================

Conseil express: sur mon site il faut fermer Firefox, supprimer l’historique + cookies, puis revenir sur mon site web pour voir les changements ~_^

Close then open to see website changes.
===========================================

Mojo themes – en ligne et en localhost

Par défaut

Bought two themes, looking at how to install them, found:

 » And each theme package you download is going to be differently organized depending on how the author wanted to do it. But for the most part every one is going to have the actual theme somewhere inside the entire ZIP package you download, because they will also most likely include other things such as documentation, PSD source files, etc.  » Jason (Theme Blvd) – Posted 3 years ago on WordPress support website.

So that means theme.zip is not the same as plugins.zip and documentation.zip.

So that means there is only one zip file inside all zip files I must upload as theme. OK!

PS: I’m not quoting theme’s name.

Installing Plugin from uploaded file: plugins.zip
Unpacking the package…
The package could not be installed. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

Déjà on peut avancer un peu avec cette info (pas à moi):

Setup Solo Creative WordPress Theme – Mojo Themes

Tools > WordPress > WordPress importer > install now > activate plugin and run importer > importer les .xml souhaités (.xml = .html, c’est une mise en forme)

Mais, non, il faut les éditer avant avec Blue Fish, les mettre en français avec les mots qu’on souhaite. Et ne pas toucher aux balises. Ensuite on importe la contact form .xml par exemple. Ce sont des pages toutes prêtes à importer. C’est bien.

Moi je veux juste savoir avec quel programme ouvrir et lire leur doc ?

The theme’s support in my theme from Mojo was great ! Ils ont résolu mon problème. C’est important le contact.

Pour la Doc, ça va.

Le plugin à dézipper c’était un sous-.zip, pas le principal.

ça ne marche pas:

The package could not be installed. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

moi j’ai trouvé:

Had the same problem, was using 472mb out of allotted 500mb’s. Changed the server to 1000mb and error stopped and plugin’s now upgrade with no problems. Needed more server space.(Silencio55@wordpress)

I had the same problem from trying to install it from the online theme. I had plenty of disk space 150GB using only 4.5MB. So I download the theme to my computer and then uploaded it via the dashboard and it worked fine. Also I had another glitch just before on a Godaddy platform with fopen() and fclose() errors that was fixed by adding
In your php.ini file, try enabling Fopen. Find the respective line and set it to be « on »:
allow_url_fopen = On
And add this line below it:
allow_url_include = 1

Now everything is working GREAT!!!! (dougison@wordpress)

Hello, I had the same problem since 2.8.2, and I solved it by commenting out mbstring.func_overload in my php.ini file:

; mbstring.func_overload = 7

Upgrades and uploads worked perfectly after that. (audioel@wordpress)

Mais moi je ne peux que faire 2 choses:

installer l’un des plugins qui augmente l’espace quand on ne peut pas soi-même le faire:

Increase Upload Max Filesize

Increase your website’s upload max filesize limit on your server by adding rules to php5.ini. If a php5.ini file does not exist on your server in the root of your website, one will be created. If your server uses php.ini instead, go to Tools -> Upload Max Filesize to run it with php.ini. You can also use this plugin to see your current php.ini settings status (go to Tools -> Upload Max Filesize).

Super Easy To Use

This is what the plugin does automatically when you install it (it works immediately upon activation):

  1. If your upload max filesize ( upload_max_filesize ) is less than 32 MB, it will be set to 32M.
  2. If your post max size ( post_max_size ) is less than 33 MB, then it will be set to 33M.

That is all. No other will rules will be changed.

If you want to set custom limits:

For custom options, go to Tools -> Upload Max Filesize. From that page, you can choose custom settings and run the plugin again.

Note:

It will only run once, upon plugin activation, or upon clicking the blue button in Tools -> Upload Max Filesize. Thus, if you later make any manual changes to decrease your upload_max_filesize, the plugin will not automatically increase it again. You must either run the plugin again from Tools -> Upload Max Filesize, or de-activate and reactivate the plugin, to make it run again.

ou

Increase Max Upload Filesize

This plugin increase upload size limit up to 250Mb and more

Very Lightweight- Only 2KB

Installation very easy, just install & enjoy.

Any problem, Please Check FAQ Tab.

  • In the admin panel under plugins page, click Add New
  • go to Upload tab
  • browse « upload_max_file_size » and click install now
  • Click Active plugin
  • Increase File size size by click on Max File Size menu on the left hand side
  • Click on max_file_size and then enter the value in bytes Like: 262144000 bytes or 262144000 (You can Enter more value how much you want)
  • Example:(Like: 262144000 bytes = 250MB)
  • Enjoy!

Les deux sont dépassés, j’essaye le dernier.

So Enter the bytes value how much you want

Mon plugin fait: 582 kilobytes = 582 000 bytes
Une petite 5 megabits = 625 000 bytes
Une grande image 10 megabites = 1 250 000 bytes
So I entered: 1250000
Now google is not anymore giving the same conversion.
Now 10 megabytes = 10 000 000 bytes
So 15 megabytes = 15 000 000 bytes
So I have to change data to: 15000000
Yep, c’était suffisant hehe. J’ai changé php.ini sans y accéder grâce à un plugin qui le fait.
Allez pour 15 megabites => 1875000 dans le plugin Increase Max Upload Filesize.
Erreur résolue.
===============================
En dehors du site:

Localhost tips:

sudo chmod u+wxr -R /var/www

Parfois il faut faire a puis réduire à u.

Fichier dézippé, mis dans le dossier /cequonveut et mis dans le localhost: /var/www/

Suivre le readme.html pour l’install.
==================
toujours dans mon PC, le localhost, apache2, enfin la reconnaissance du .php par Firefox ça marche pas, j’essaye de suivre plein de choses au même temps
http://localhost —> le tout beau it works avec du rose et tout de Ubuntu
sudo gedit /etc/apache2.conf
ServerName localhost
sudo gedit /etc/apache2/httpd.conf
ServerName localhost
sudo gedit /etc/hosts
127.0.0.1 localhost
etc.
sudo chmod -R a+wxr /var/www
sudo apt-get autoclean
Firefox > Préférences > Avancé > Réseau > (tout fermer pour ne rien perdre) puis Vider maintenant.
J’ai trouvé l’erreur, Firefox n’ouvre pas les .php si on n’indique pas leur adresse correctement: http://127.0.0.1/phpinfo.php pour un fichier situé dans: file:///var/www/html/phpinfo.php

hello, so now for error:

Connection Information

To perform the requested action, WordPress needs to access your web server. Please enter your FTP credentials to proceed. If you do not remember your credentials, you should contact your web host.

yes so:

http://linuxconfig.org/how-to-setup-and-use-ftp-server-in-ubuntu-linux

sudo apt-get install vsftpd
vsftpd est déjà la plus récente version disponible.
sudo service vsftpd start
start: Job is already running: vsftpd
sudo apt-get install xinetd
which vsftpd
/usr/sbin/vsftpd
(that address is mine and important, you're going to put yours on: server line.)
(the rest I don't understand.)
gedit /etc/xinetd.d/vsftpd
Quote from http://linuxconfig.org/how-to-setup-and-use-ftp-server-in-ubuntu-linux:

Next, create a file called vsftpd in /etc/xinetd.d/ with the following content:

service ftp
{
        disable                 = no
        socket_type             = stream
        wait                    = no
        user                    = root
        server                  = /usr/sbin/vsftpd
        per_source              = 5
        instances               = 200
        no_access               = 10.1.1.10
        banner_fail             = /etc/vsftpd.busy
        log_on_success          += PID HOST DURATION
        log_on_failure          += HOST
}

yep, then following this site, pour qu’il ne laisse pas de port ouvert pour le superserveur xinetd.

gedit /etc/vsftpd.conf

listen=NO

then

sudo service vsftpd stop; sudo service xinetd restart; netstat -ant | grep 21

vsftpd stop/waiting
xinetd stop/waiting
xinetd start/running, process 20376
tcp 28 0 192.168.0.11:58321 91.189.92.23:443 CLOSE_WAIT

Revenons en arrière, j’ai dû mettre listen NO pour IPV6 afin que ça marche. En avant maintenant.

En arrière encore, j’essaye de modifier cette partie:

sudo gedit /etc/vsftpd.conf

listen_ipv6=NO
#j’ai changé en haut YES pour NO
# Allow anonymous FTP? (Disabled by default)
anonymous_enable=YES
#j’ai changé en haut NO pour YES
#
# Uncomment this to allow local users to log in.
local_enable=YES

suite

sudo service vsftpd stop; sudo service xinetd restart; netstat -ant | grep 21

Put NO password:

fran@earendil-light:/$ ftp localhost
Connected to localhost.
220 (vsFTPd 3.0.2)
Name (localhost:fran): anonymous
331 Please specify the password.
Password:
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> quit
221 Goodbye.
fran@earendil-light:/$

Là ça marche comme cela.

sudo gedit /etc/vsftpd.userlist

marisedecorart
faietdohrnii
fran

sudo gedit /etc/vsftpd.conf

#Added by me:
userlist_file=/etc/vsftpd.userlist
userlist_enable=YES

thanks: http://linuxconfig.org/how-to-setup-and-use-ftp-server-in-ubuntu-linux

Now let’s see if it works ?

No, did not manage to have users+passwords. So I can’t connect.

Ubuntu Utopic Unicorn 14.10

Par défaut

Je l’ai installé parce qu’il est la seule version d’Ubuntu compatible avec mon imprimante pro d’occasion (logiciel = paquet: HPLIP). La mise à jour de Trusty vers Utopic je l’ai faite de l’intérieur sur le terminal en suivant la doc. Le double boot n’a pas été altéré ni touché. Par contre les dépôts j’ai dû tous les re-installer. Ce n’est pas une LTS mais je m’en tiendrais comme si c’en était une. Donc j’ai:

lsb_release -a
No LSB modules are available.
Distributor ID:    Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:    utopic

  • Dépôts Launchpad:

sudo add-apt-repository ppa:ubuntu-wine/ppa; sudo apt-get update; sudo apt-get install wine

sudo add-apt-repository ppa:yannubuntu/boot-repair; sudo apt-get update; sudo apt-get install boot-repair

sudo add-apt-repository ppa:webupd8team/java; sudo apt-get update; sudo apt-get install oracle-java8-installer

  • Dépôts Ubuntu Update: pour l’instant aucun.
  • Google Earth:

sudo apt-get install ttf-mscorefonts-installer qt4-qtconfig

https://www.google.fr/intl/fr/earth/download/ge/agree.html

sh fichier.deb (je vais encore voir)

  • Chromium (et sa version non-free Google-Chrome).

Pendant longtemps des bugs. J’ai arrêté de me connecté sous mon compte Google pour éviter les bugs. Adobe flash player je l’ai installé mais il n’est ni compatible Firefox ni compatible Google. Je ne sais pas quel est le flash que Firefox utilise puisque Adobe n’était pas installé avant ?! Peut-être flash icedtea ? En tout cas il est très correct car je joue avec.

Pour Chromium c’est : sudo apt-get install pepperflashplugin-nonfree

Les polices de caractère recommandées pour Firefox et Chromium sont:

sudo apt-get install ttf-dejavu ttf-mscorefonts-installer ttf-xfree86-nonfree gsfonts-x11

  • Firefox

Ce dépôt fournit à la fois Firefox et Chromium en flashplayers récents.

sudo add-apt-repository  ppa:andykimpe/freshplayerplugin-daily

Pour Firefox c’est freshplayerplugin mais ce n’est pas celui que j’utilise actuellement.